[Userscript] Wanikani Mistake Delay (new, version 2.x)

Wanikani Mistake Delay

For you speed-demon reviewers who are in the habit of double-tapping the <enter> key after a correct answer so you can quickly move on to the next item…

…but sometimes you accidentally double-tap after a wrong answer, which prevents you from seeing what you did wrong.

This script prevents the double-tap for 2 seconds when you answer incorrectly.

Download

:point_right: Download from greasyfork.org :point_left:

Settings

There are several settings you can change near the top of the script:

    //==[ Settings ]=====================================================
    var settings = {

        // Amount of time to delay (in milliseconds).
        delay_period: 2000,

        // Delay when answer is slightly off (e.g. minor typo).
        delay_slightly_off: 1,

        // Delay when multiple answers are available.
        delay_multiple: 1
    };
    //===================================================================

History

[v2.0.1] - Added options for delay upon multi-answer or slightly off answer.
[v2.0.0] - Initial release

Credits

The original concept for this script comes from @ruipgpinheiro in this thread.

21 Likes

Ahhh, this is exaclty what I needed. Thanks for the update!

Can you make it delay for “There are Multiple Readings” unless you use [Userscript] Wanikani Multiple Answer Input?

^^^ I can add an option that you can manually enable. That way it’s not dependent on detecting other scripts.

But not today. Time to sleep :slight_smile:

[Edit: And also a separate option for “your answer was a little bit off”]

This is excellent, thanks.

This has been the bane of WaniKani for me (specifically when doing radicals).
Thank you so much rfindley :kissing_heart: (in a platonic way).

:point_right: [v2.0.1] - Added options for delay upon multi-answer or slightly off answer. :point_left:

(See settings near top of script)

Do you have an idea why it just stops working if I enounter the ‘multiple readings’ or ‘looking for on’yomi/kunyomi’ messages pop up? The input area just turns gray, enter isn’t working anymore and the only way to fix it is to manually click on the submit button (which completely breaks my workflow).

Some more information:

  1. I’m using Firefox v. 58.0 64-Bit with Tampermonkey 4.5.5660.
  2. It only happens after about 1 second has passed.
  3. I have the following scripts installed:
    2018-01-21 22_15_36-

The combination of [But No Cigar], [Mistake Delay], and [Lightning Mode] is particularly messy. All three interact with the review process, so it’s not surprising that some things get weird.

I think I’d probably recommend dropping [But No Cigar], [Mistake Delay], and [Override], and switch to [Double-Check] instead. It’s basically a combination of all of those three, plus an ability to mark right answers wrong if WK’s typo-forgiveness gets too lenient and marks one correct that shouldn’t really be.

By default, the [But No Cigar] feature is turned off, but you can enable it at the top of the script by setting the following to 1:

shake_when_slightly_off: 1,

As far as I know, [Lightning Mode] should also work with [Double-Check]. If not, it would be easy for me to add a Lightning Mode option to [Double Check].

The hotkeys for [Double-Check] are [here].

Just started using this script, it’s awesome! Thank you @rfindley ! :slight_smile:

However, I noticed a bug. When I enter the wrong reading for a Kanji (Kun’yomi instead of On’yomi, for instance), the input field becomes blocked and I can’t type anything. The only workaround is to click on the “next” button and wait for the item to appear again. This doesn’t appear to affect the review.

Thanks for the bug report! I’ll take a look sometime tonight.

(Now that you mention it, this sounds familiar. :thinking: I wonder if I fixed it on Double-Check (which contains mistake-delay), but not on this script. Either way… I’ll check it out)

:point_right: [v2.1.1] - Fix disabled input box when wrong yomi.

Hey it seems like this script activate itself everytime whether you’re wrong or not I guess it’s due to one of the recent WK update

Since Mistake Delay is built into Double-Check, I’m not planning to maintain this one. So, I’d recommend switching to Double-Check. If you do switch, be sure to look at the options near the top of the script to configure Mistake Delay how you want it. There may also be a settings menu soon, though no guarantees.