[Userscript]: Double-Check (Version 2.x)

@strae,

On GreasyFork, your comment said you had cleared cache, which clears settings for the script. Make sure your settings in Double-Check are set to what you expect them to be.

Also, you didn’t mention exactly what isn’t working for you. Are you getting an error?

1 Like

So earlier I was getting the same error as everyone else, but the second time it stopped working there was no error. The settings are what they should be, I have the framework set first. When I open a review, I can see the little number of scripts running change on the tamper monkey icon, so it does recognize it’s supposed to be there, but it isn’t, and other script for font variation is working. I tried uninstalling and reinstalling everything to no avail. Finally I gave up and switched from Chrome to Firefox, thinking that would work, but it’s not coming up there either. I was hoping I was just missing something obvious, like the above mention to be running the latest version, but I was already doing that. I THINK I did all the normal troubleshooting that someone that doesn’t actually know anything about coding would do. But no idea what I’m missing. I’m hoping it’ll just pop back up on its own, because honestly I tend to have really bad one-off weird tech luck. :woman_shrugging:t2:

If you haven’t already, check for errors in the Javascript console: Press F12 to open the developer tools, and click on the Console tab. Post any errors you see there.

It’s blank, it only has a little message saying this some things that used to generate a console message are now listed under “issues” and asking me if I want to see the one that comes up there, which is: Audit usage of navigator.userAgent, navigator.appVersion, and navigator.platform. - Which honestly, no clue what that even means, so I think I’m probably just SoL. But I do appreciate the time you took trying to help, do you have a CashApp or Venmo or something?

Hmm… Are you at least able to access settings from the menu in the upper-left corner of the review screen?
image

No need for tip or donation. I’m happy to help when I have time.

1 Like

Omg, thank you so much! It’s working now. Just like before, (can’t remember if last night or this morning) I just went in to add my custom settings, except this time it looked like they were already the ones I picked, so didn’t actually expect anything to happen, but when I hit save this time it started working! Yay! So happy! Maybe I’m an idiot and didn’t hit save last time? But then it should’ve been the default settings showing instead of mine? Idk, maybe they were the default ones but looked like mine and I just wasn’t fast enough to catch the default time allowance or something? Either way, woohoo! Thank you, and I definitely think people should be more in the mindset for compensating people for their time like artists or freelancers or people providing a useful service and taking their valuable time to help clueless people like me. Lol. Thank you!

1 Like

Hey,
I’ve been having the issue of the various popups upon entering something in a review appearing far, far right, instead of center below the text field. Disabling Double Check fixes it. Disabling all others does not fix it. Any ideas; or did I miss something? ;_;

screenies


Is there a way to have double check show the multiple answers below your entry versus opening the drop-down info menu? The latter usually has the answer to the meaning of the vocab/kanji in their examples when testing reading first and I want to avoid this. I also noticed if the option for double check is disabled that wanikani doesn’t open the prompt telling you a kanji has multiple readings/meanings.

I remember another script did something similar but can’t remember the name or if it still works.

This script does it for me.

2 Likes

Guess I had it already but forget it needed setting up in the dashboard menu.

Thanks for the help!

The Double-Check functionality seems to still be working, but I’m not currently able to access this menu.:point_up_2: I can still enable/disable lightning mode by clicking the button (even though there is no visible icon).

FWIW, I also use a script to hide the stats on the right – which has also stopped working. I’ve tried using each of these scripts separately (with & without script compatibility mode) and it hasn’t made any difference.

I have a similar problem. I installed the script today and it worked fine for a session, but after coming back after a few hours the setting gear was gone and the buttons aren’t displayed correctly anymore.

I can still enable lightning mode and use the buttons through the hotkeys, but I can’t access the settings.

This error occured after I installed this script: [Userscript] WaniKani Hide Buttons in Review

I already tried to deinstall all scripts and I reinstalled the Open Framework script and the Double checker script and it still doesn’t work. I even reinstalled Tampermonkey but that didn’t solve the problem either.

I am at my wits end…

The script has stopped working for me today as well. I tried turning off all of my other scripts, and it didn’t help. This is most likely my favorite WK script, so I hope you can figure out what’s up, rfindley! Thanks for your hard work.

@jc04tu @SolemnV @tealsummernights,

Wanikani changed some stuff related to icons. I’ve posted fixes to several of my scripts, including:

:point_right: [Open Framework]
:point_right: [Double-Check]
:point_right: [Ultimate Timeline]
:point_right: [Self-Study Quiz]

Note: Sometimes greasyfork.com doesn’t show the latest version immediately. You may need to refresh the page to see the latest. Or try checking the ‘history’ tab on greasyfork to make sure the version you are installing says it is from today.

10 Likes

Thanks so much!

I seem to have the latest scrips but it’s still not working. Maybe WK have changed something again?

@notaz,

Do you have Wanikani’s “Script Compatibility Mode” turned on? The changes I made aren’t necessarily compatible with that mode.

Check the Javascript console to see if there are any errors (Press F12 and click on the Console tab).

ok the issue seems to be firefox’s “private window”. I use it because I don’t want to leave history traces (or not having to remember to clear history every time). I don’t mind the longer loading times because of missing indexedDB, and all scripts I need used to work until now. Here is an error from the console:

Uncaught (in promise) undefined Wanikani Open Framework.user.js:354:18
    error moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:354
    (Async: EventHandlerNonNull)
    file_cache_open moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:345
    startup moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:579
    <anonymous> moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:582
    <anonymous> moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:584
    s eval:4
    <anonymous> moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:1
    <anonymous> moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:1
    <anonymous> moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:585
    <anonymous> moz-extension://f9ef3835-632c-4bd7-81b1-15d36551b03a/userscripts/Wanikani Open Framework.user.js?id=9b0b7f5d-a217-4ba7-80f8-f4ad67d498b8:587

If you want to operate without indexeddb, you can edit your local copy of Open Framework. On line 20, change ignore_missing_indexeddb from false to true:

    var ignore_missing_indexeddb = true;

Alternately, rather than using ‘Strict’ mode in Firefox, you could use ‘Custom’ mode and use a plugin like [Cookie Auto-Delete] to manage your browser data more flexibly. For example, you can set it to clear all data (including indexeddb) upon closing a tab or leaving a domain. That way, you get full site functionality, but the data is still deleted afterward. And you can do it on a site-by-site basis.

Hiya, do you accept additional feature contributions?

I wanted to override lightning mode and show Item Info only for vocabulary readings (same as requested in this Topic). That combined with WaniKani Pitch Info and autoplaying the readings is helping me remembering intonations.

Diff from Double-Check 2.2.37
@@ -62,7 +62,8 @@
             autoinfo_correct: false,
             autoinfo_incorrect: false,
             autoinfo_multi_meaning: false,
-            autoinfo_slightly_off: false
+            autoinfo_slightly_off: false,
+            autoinfo_always_vocab_readings: false
         }
         return wkof.Settings.load('doublecheck', defaults)
             .then(init_ui.bind(null, true /* first_time */));
@@ -121,6 +122,7 @@
                         autoinfo_incorrect: {type:'checkbox',label:'After incorrect answer',default:false,hover_tip:'Automatically show the Item Info after incorrect answers.', validate:validate_autoinfo_incorrect},
                         autoinfo_multi_meaning: {type:'checkbox',label:'When multiple meanings',default:false,hover_tip:'Automatically show the Item Info when an item has multiple meanings.', validate:validate_autoinfo_correct},
                         autoinfo_slightly_off: {type:'checkbox',label:'When answer has typos',default:false,hover_tip:'Automatically show the Item Info when your answer has typos.', validate:validate_autoinfo_correct},
+                        autoinfo_always_vocab_readings: {type:'checkbox',label:'Always after correct vocabulary reading',default:false,hover_tip:'Automatically show the Item Info when you answer vocabulary readings (to show reading/pitch info).'},
                     }},
                 }},
             }
@@ -603,7 +605,13 @@
                 }
 
                 set_answer_state(answer, true /* show_msgs */);
-                if (settings.lightning_enabled) {
+
+                var showVocabReading = settings.autoinfo_always_vocab_readings && itype === 'v' && qtype === 'reading';
+                if (showVocabReading) {
+                    $('#option-item-info').click();
+                }
+
+                if (settings.lightning_enabled && !showVocabReading) {
                     new_submit_handler(e);
                 }