[Userscript]: Double-Check (Version 2.x)

:point_right: [v2.2.32] - Fixed interception of review ‘submit’ button after WK change.

@Antjinn @DiSiZ @guiljb @Held @ichigomoon @Mirabilia @phoenixalia @sbheinlein @Swazmataz @TeaSouple


More tags:
@Thbvrd @Toyger @WaywardStrike @will_riker


If you’re not seeing v2.2.32 yet when you click on the link above, maybe try [this] link, which goes directly to the new version (rather than “latest”, which GreasyFork apparently hasn’t updated yet).


Many thanks for the update.

1 Like

What a quick fix! Thank you :slightly_smiling_face:

1 Like

Thanks for the update !

1 Like

Thank you for the quick fix!

1 Like

God bless you @TeaSouple, fixer of the bugs.

It seems lightning mode has stopped working in 2.2.32 unless script compatability mode is enabled

Big thanks! :heart:

:point_right: [v2.2.33] - Fixed Lightning Mode after WK update.


Is it just me or does lightning mode now flash the current item before moving onto the next one, making the thing incredibly painful to look at?

EDIT: Or maybe I’m describing it wrong but it definitely looks odd to me.

1 Like

I can’t see any flicker/flash, but I can think of a possible reason why it might.
Try the following to see if it helps:

:point_right: [v2.2.34] - Attempt to remove flicker when submitting reviews with lightning mode


Also noticed a subtle flickering with 2.2.33 but looks like this has resolved it. Thanks!

1 Like

Yup, works exactly as it always used to now. Thanks!

1 Like

Working now for me too, thank you! :smiley:

Though there is still this very minor bug: after entering your answer, the speech bubble that pops out is under the wrong button (under ‘Kana Chart’ now instead of ‘Item Info’), probably because of the added buttons. Again, nothing system-breaking, just trips me up every now and then.

Thank you so much for fixing it and for this script in general. Have a nice day.

So it is currently working for you now? I tried it on Chrome and Firefox with no luck. Not sure what my issue is? :confused:

if you go to the dashboard of the Tampermokey extension (click on its icon on your browser to select the dashboard), you can click on the last update time. This will trigger the download of the last version that should be 2.2.34.

Hope this helps



On GreasyFork, your comment said you had cleared cache, which clears settings for the script. Make sure your settings in Double-Check are set to what you expect them to be.

Also, you didn’t mention exactly what isn’t working for you. Are you getting an error?

1 Like