[UserScript] Condensed Progress Bars


#1

I wanted to change up the progress bars a bit, so here we go.  They’re condensed so the 0 and X numbers are inside the bar, and the goal now states the number of kanji needed, instead of 90%.  As well as a couple other minor things


Note: image is out of date.  The gear icon is gone.  Settings are found under ‘Menu’ at top.

https://greasyfork.org/en/scripts/22648-wanikani-condensed-progress-bars


The New And Improved List Of API and Third Party Apps
App Store script
[Userscript] Dashboard Progress Plus
[Userscript] Dashboard Progress Plus
The 0/0 Streak Challenge
#2

Nice. Installed.


#3

Nice. Can you remove that cog on the top left?


#4
Aleithian said... Nice. Can you remove that cog on the top left?
 Problem is, we need a way to access the settings.  Granted right now there really isn't any settings other than api key, but I may introduce more.
I am toying with the idea of adding the settings for my two scripts into the 'Menu' at the top right.  I'll probably play with that idea when I get some time.

Edit: Toying complete

#5

I downloaded the script you have mentioned above, but the 90% still says “90%” and not the actual number. Is the script online updated yet? Or is it because I haven’t guru’d anything yet?

Edit: It has the settings gone so I tried that, but it gave me only a line to enter the API key as well as the save/cancel buttons… I entered my API key but now it’s telling my API key is invalid so… I’m not sure.


#6
JackTsuchiyama said... I downloaded the script you have mentioned above, but the 90% still says "90%" and not the actual number. Is the script online updated yet? Or is it because I haven't guru'd anything yet?

Edit: It has the settings gone so I tried that, but it gave me only a line to enter the API key as well as the save/cancel buttons... I entered my API key but now it's telling my API key is invalid so... I'm not sure.
 Shouldn't have to guru anything, I just guru'd my first level 15 so I have tested with 0 gurus.  Are the numbers still showing below the bars?  if Goal: 90% is still showing, it sounds like something is keeping the script from running in the first place.  If your'e getting the 'API Error:', that means the api call itself is failing, so I'm not getting any data to work with, and just exiting out.  I hate to ask the question, but you're sure you entered the api correctly?  No leading/trailing spaces or anything?

Edit: Still haven't guru'ed and level 15 kanji.  I had a math error, oops.

#7

Great idea, but I’m having some issues with this as well.
When I click the gear icon to setup my API key it looks… weird: http://i.imgur.com/2g74U1f.png
And then when I input my key and reload the page I get an error message saying my API key is invalid:http://i.imgur.com/2FaV53n.png
The browser console shows that a the following request is made, but of course it doesn’t work since the API key is missing: https://www.wanikani.com/api/user/undefined/level-progression


#8

Really nice idea!

The ‘progress indicator box thing’ seems to hover 1cm to the left of the actual progress bar on 0% (its center is just on the border of the gray container box), but that’s just aesthetics.

Note: the API key doesn’t save correctly with me either, but I still got it to work by manually entering it in the console. A lot of people have already stored their API key in localStorage for scripts by Rfindley and me. It can be accessed by

 localStorage.getItem(‘apiKey’);



#9
DaisukeJigen said... Shouldn't have to guru anything, I just guru'd my first level 15 so I have tested with 0 gurus.  Are the numbers still showing below the bars?  if Goal: 90% is still showing, it sounds like something is keeping the script from running in the first place.  If your'e getting the 'API Error:', that means the api call itself is failing, so I'm not getting any data to work with, and just exiting out.  I hate to ask the question, but you're sure you entered the api correctly?  No leading/trailing spaces or anything?
 I'm having the same problems as Kantana. Since it wasn't working I figured I needed to adjust the settings but it looked weird as shown in their image. And then after I put it in, it kept giving me the error message.

Kantana said... Great idea, but I'm having some issues with this as well.
When I click the gear icon to setup my API key it looks... weird: http://i.imgur.com/2g74U1f.png
And then when I input my key and reload the page I get an error message saying my API key is invalid:http://i.imgur.com/2FaV53n.png
 
Mempo said...Note: the API key doesn't save correctly with me either, but I still got it to work by manually entering it in the console. A lot of people have already stored their API key in localStorage for scripts by Rfindley and me. It can be accessed by

 localStorage.getItem('apiKey');
 So it sounds like this could fix this for me, but I'm not a programmer so I don't even... know how to do this. Or if this was even at us or if it was at Daisuke.

Anyways, it looks cool so I'm really hoping that either you can fix the script if there's something wrong there, or you can fix me if it's a user error :)

#10

Um, just thought I’d add that it’s working fine for me…


#11
JackTsuchiyama said... So it sounds like this could fix this for me, but I'm not a programmer so I don't even... know how to do this. Or if this was even at us or if it was at Daisuke.

Anyways, it looks cool so I'm really hoping that either you can fix the script if there's something wrong there, or you can fix me if it's a user error :)
 Meant it for OP, but you can fix it yourself if you want. But it's probably better to just wait a bit until OP fixes this for all.

#12
EskimoJo said... Um, just thought I'd add that it's working fine for me...
 Teach me your ways :'(

#13

How cool! I’ll check it out


#14

When I first read the title, I thought that it said “condescending progress bars”… Pretty curious about how that’d turn out. 


#15

It says API invalid for me as well. 


#16

I could only get it to work by modifying the script to set my API key manually. I had the same issue as others are reporting. I’m using Chrome with Tampermonkey if that helps.


#17

Ok, sounds like the css for the dialog isn’t loading.  Works for me as I have the css loading for other reasons as well.  Taking a look now.

Yep, I wasn’t loading the jquery-ui css.  The other script I wrote loads it, which is why I failed to see it in initial testing.
Now, if you have both scripts active, it will load the css twice.  No real harm in that, but I’ll see about doing a check first anyways.

The api key thing, stupid mistake on my part.  The textbox wasn’t being called correctly.

Both issues should be resolved.


#18

Thanks for the update. Works great without having to hardcode the key now.


#19

Could you fix the position of the percentage indicator, please? And  also the SRS Grid  still doesn’t seem to work with Clean Dashboard enabled.



#20
embe said... Could you fix the position of the percentage indicator, please? And  also the SRS Grid  still doesn't seem to work with Clean Dashboard enabled.

 The 0% indicator alignment will be getting an update, don't worry.
SRS Grid with clean dashboard is a bit harder.  Clean dashboard is basically overriding what I'm doing with the SRS Grid.  I'll keep working at it, but it won't be a speedy fix.