Input box keeps loosing focus and double submitting

Ever since this morning the input box will lose focus randomly for me and it’s incredibly distracting and slow to have to re-click it all the time. I am using these 2 userscripts:

3 Likes

Have you tried to reproduce without any userscripts running? I’ve had to previously disable the Semantic-Phonetic one because it was causing me other issues in my Safari browser.

You probably should disable all scripts, see if you can reproduce. If not, add them back in one at a time until you can repro then alert the authors to the issue so they can fix.

Just as a second data point, I can’t reproduce the issue on either Safari on my Mac and iPhone or Chrome on Windows.

I can reproduce the issue with the Double-Check script.

The issue occurs once you correctly answer the second part (either meaning or reading) of a vocabulary or kanji. As soon as that happens, the review becomes “broken.”

I have multiple scripts running, and when I turn off Double-Check the reviews work as expected.

1 Like

Makes sense why it doesn’t repro for me, I don’t use that one. :slight_smile:

I’ve just had something similar happen to me. I tried another set of reviews with all scripts disabled and they worked fine.

I think it’s probably the Double-Check one that needs looking at. Looks like a problem has been identified in that script’s forum thread but no fix before the weekend.

Suggest either disable that one, or turn on Script Compatibility Mode.

2 Likes

Same issue here. Once I disabled Double-Check it’s fine. Does anyone have a similar script to use in the meantime?

You may try turning on Script Compatibility mode until the problem is fixed. Check the Double Check thread for updates.

1 Like

Hello, I had the same issue, I turned on the Script Compatibility Mode, on the app settings menu. It worked for me… good luck on that.

Compatibility mode works for me! There is a little chain on the main double check thread where the developer has said he will look into a fix soon.

I have the same problem, also using Double-Check and some other scripts. Compatibility mode fixed it for me. I think the cause might be the newest update v3.0.0: Script Compatibility Mode | WaniKani Knowledge. It was rolled out only two days ago.