My scripts aren't working

I don’t know what happened. Does anybody know how to fix this? I’m using tampermonkey if that will be of any help.

I’ve tried disabling and enabling the scripts, I’ve tried reinstalling one script which didn’t work (which is why I didn’t bother with the rest of them), and that’s it. Is there a way to fix this?

i’ve had to restart my browser in the past, and recently someone said that depending on which scripts one had, restarting the browser with the page for an item (radical, kanji, vocab) open could make scripts not work…

I tried restarting just now, and it didn’t work. Do you have any other ideas on how to fix this?

dunno… …i’d check for updates for browser and scriptmanager, then disable them all and turn them on one by one…

Do you use Keisei Semantic-Phonetic composition script? If you have the Wanikani dashboard tab selected when you close your browser with this script enabled it will cause all your Wanikani scripts to stop working. Closing your browser with another tab selected works around this problem.


I had a similar problem too, way I solved it was disabling Tampermonkey on my browser then reenabling it.

Try restarting Tampermonkey (through the Tampermonkey settings page). If that doesn’t help then try restarting Firefox but closing all the Wanikani tabs before doing it (the reason for that is not to have Wanikani tabs open with the browser - I suspect Tampermonkey needs time to kick off before running any scripts).

So that’s the script to blame, huh…

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.