Community.Wanikani displays Chinese glyphs, not Japanese

E.g. 降る or 直す are rendered in Chinese manner in chrome:

image

It’s not a font issue issue, it’s an issue of the site not having lang="ja", for example

e.g. it can be fixed (for editor) by editing d-editor-container

3 Likes

Wouldn’t this be happening all the time if there was an issue generally with the site? Every once in a while we get a question about Chinese versions, usually as a result of device settings for that particular user.

I’ve never edited anything like that, but never experienced an issue on any device.

2 Likes

Main site(wanikani.com) is aware that you need to specify lang to correctly render kanji, so browser knows what to display:

.

Community.wanikani.com site doesn’t.

1 Like

Okay… but I imagine we should be seeing a flood of questions about it all the time if everyone is seeing the Chinese versions of characters on the community page. But we don’t. I’m wondering why.

I mean I’m also seeing the Chinese characters, I just don’t really mind. Though if I were to know how to change it, I would.

There is a large amount of people noticing those specific character maykeye mentioned, and recently also this one 誤 by Trunklayer

I’ve noticed it before with 直 too on Chrome, but didn’t know enough to know what was going on. I assumed it might be just a font difference.

It sounds like only occasional unicode characters have this setting matter with them:

Japanese users prefer to see Japanese text written with “Japanese” glyphs.
There are occasional instances of unified characters whose typical Chinese glyph and typical Japanese glyph are distinct enough that the Chinese glyph will be unfamiliar to the typical Japanese reader, e.g., 直 U+76F4. To prevent legibility problems for Japanese readers, it is advisable to use a Japanese-style font when presenting Unihan text to Japanese readers.

From: FAQ - Chinese and Japanese

Um… So Furigana changes it… :thinking: That’s neat I guess… 空 (そら) (I used the same character here, or tried to anyway)

3 Likes

I’m guessing there is at least some device setting involvement, because on my work computer, using Chrome, everything always showed Japanese characters, and I haven’t done anything to edit anything.

But I’m in Japan, so presumably there is some setting on the device overriding it.

This is how it appears to me, having done nothing in particular to change anything. It looks different for you?

Has everyone just been looking at Chinese versions but not been asking about it?

3 Likes

Sounds like it!

For optimal results a system localized for use in Japan, for example, should use a font designed explicitly for use with Japanese, rather than a generic Unihan font.

(from the same page)
This was pretty interesting!

The key is it sounds like it’s unicode’s fallback in a way - some characters look odd for all possible languages (I’d imagine those expecting simplified Chinese characters would notice instantly, for example).
Since the language is unset, it’s not Chinese or Japanese, it’s just… unicode.


Yeah this is the only one I’ve overtly noticed so far. I think most just assume it’s a font difference.

4 Likes

I had noticed the same problem regarding 直 and had a discussion here.

This solution worked: you have to set Japanese as one of your preferred languages in your browser’s settings.

6 Likes

Ah it’s because I’m using a script that actually specifies Japanese automatically.
<ruby lang = 'ja-JP'>空<rp>(</rp><rt>そら</rt><rp>)</rp></ruby>

2 Likes

Took less than 30 seconds and worked like a charm. ありがとう!
image

1 Like

This solution breaks other (admittedly broken) sites. For some reason minecraft.net starts displaying Japanese version.

2 Likes

Japanese must be one of the preferred languages, but not the only one. Do you have English among the preferred languages in your settings?

This is for my Firefox:
image

3 Likes

Weird.

I had a phone that used to show Chinese versions for any Japanese if I had my default language as English. My current phone doesn’t have the same issue.

But any time I had my phone set to English I couldn’t stand the Japanese showing Chinese versions, but maybe that’s just my low tolerance.

I have 2 versions of EN and 1 of RU

image

Minecraft definitely supports ru-ru and en-us, but no matter where I put Japanese in preferred language list, it displays Japanese version.

(I also have very strong belief that users shouldn’t change system or browser settings)

It does also sound like the initial feedback is valid since it’s a Japanese language learning forum and all.
It should probably have the characters set to Japanese by default, to avoid ignorant folks like me with non-Japanese setups from making the same (minor) mistake of not noticing.
Seems like you can change them with tags if other forms are specifically needed for some reason.
(assuming that applies to potential site-level fixes and all that anyway)

1 Like

Couldn’t get mine into English, but it does like Spanish now. It’s a redirection problem so if you use the language options at the bottom or a direct URL like minecraft.net/en-us it works. I imagine this sort of solution should work in the vast majority of cases.

EDIT: After using the en-us page, my browser seems to remember that preference and redirects there from minecraft.net on it’s own now. So that’s good.

I have never used minecraft.net, but yes, you are right. With my settings, minecraft is Japanese. I don’t know why … (good for your immersion to Japanese? :wink:)