Wanikani Override Userscript 1.1.2 ("Ignore Answer" Button) [No longer supported]

I still use the original and it works fine.

the original stopped working, so I used  Beannow’s version. Thanks for making it ^___^

kineli said... the original stopped working, so I used  Beannow's version. Thanks for making it ^___^
 Seconded!!!
Naerro said...
kineli said... the original stopped working, so I used  Beannow's version. Thanks for making it ^___^
 Seconded!!!
 Could you please link me that "Beannow" version?  Thank you very much.
maypassion said...  Could you please link me that "Beannow" version?  Thank you very much.
 It's just higher in the thread (previous page):

Beanow said... I fixed this issue for me here:
https://gist.github.com/Beanow/9ea55a4d73d6156f01c9
Only tested on Firefox 31.0a2 (Linux x64; Aurora)

Beanow said... I fixed this issue for me here:
https://gist.github.com/Beanow/9ea55a4d73d6156f01c9
Only tested on Firefox 31.0a2 (Linux x64; Aurora)
 Hey Beanow!

Thanks, man!   Totally works on FF 31.0.   Terrific!

Would it be possible to make it work under Chrome 36.0?    I don't know much Javascript at all, and I'm really helpless when it comes to tinkering with other peoples' Javascript.

I switch back and forth between FF and Chrome all the time... would you happen to know how to get this to work under Chrome?   :)
caffeine said...  Hey Beanow!

Thanks, man!   Totally works on FF 31.0.   Terrific!

Would it be possible to make it work under Chrome 36.0?    I don't know much Javascript at all, and I'm really helpless when it comes to tinkering with other peoples' Javascript.

I switch back and forth between FF and Chrome all the time... would you happen to know how to get this to work under Chrome?   :)
 The reason the script was changed in the first place is because Mozilla made changes to unsafeWindow for the addon-sdk in Firefox 30.0. Chrome to my knowledge did not make any similar changes. Therefore Beanow's version (which works beautifully with Firefox) is probably not going to work with chrome.

Now I don't use Chrome myself but I just tried version 36.0.1985.143 on x64 linux with the original script, a mirror of which can be found here https://greasyfork.org/scripts/701-wanikani-override. It works fine for me. The only thing that doesn't work is the hotkey to ignore the answer but that's because my keycode for (~) is different than normal. If you have a similar issue that's very easy to fix, just find out what keycode your tilde is then change the number in the script.

Maybe it is still broken for you however, but if you haven't tried the original under chrome then it's worth a shot.



Thanks Beanow!

If anyone’s having problems figuring out how to implement the fix, follow these steps:

Goto: https://gist.github.com/Beanow/9ea55a4d73d6156f01c9

Click the button that says: Download Gist

Save the .rar file.

Extract the contents.

Find the file wko.user in the folder.

Run the file with FireFox.

Profit!

Note: You need greasemonkey installed first.

^ You can just press the ‚ÄúRaw‚ÄĚ button in the top-right corner, and then confirm the installation. Done!

Since the original script is broken on a few setups, this might not help much, but seeing as userscripts.org is no more,  I reuploaded my last version (along with the rest of my Wanikani userscripts, but I digress) onto my personal server at http://files.ruipinheiro.eu/wanikani_scripts/

Glad to see development on the script has kept up, though :slight_smile:

Hey. This script makes the reading and meaning occur successively. Is there any way to turn this off?

Frusen said... Hey. This script makes the reading and meaning occur successively. Is there any way to turn this off?
 I don't remember if you can change that (I think you can't)

However, this extension will do what you want: /t/WK-Customizer-Reviews-Timeline-Pairing-and-Sorting/2163/1




dwarefy said...
Frusen said... Hey. This script makes the reading and meaning occur successively. Is there any way to turn this off?
 I don't remember if you can change that (I think you can't)

However, this extension will do what you want: /t/WK-Customizer-Reviews-Timeline-Pairing-and-Sorting/2163/1

 Had totally forgotten I'd downloaded this >.>

Turned off all the reordering boxes and it fixes THANK YOU <3<3<3

I know this script is no longer supported but has anyone encountered a problem like not being able to click the ignore button after a typo? It was as if the button was just a text :S

cheru said... I know this script is no longer supported but has anyone encountered a problem like not being able to click the ignore button after a typo? It was as if the button was just a text :S
 /t/WK-Override-fixed-for-Greasemonkey/7428/1

That worked, thank you^^

Okay, seriously, this is not working for me. Not on Firefox not on Chrome. Guys.

Hm, works perfectly for me in Chrome. Do you have tampermonkey (Chrome) / greasemonkey (Firefox) installed and enabled? Can’t think of any other possible problems, sorry.

Just installed and it works for me (as of May 2015) using tampermonkey and Chrome. Just had to load the script link a couple of times before it would show up in tampermonkey and not get autoblocked by Chrome’s script block system (pop up message that tells you to only install scripts through the Chrome extensions store)

This doesn’t work for me - I’m using firefox and greasemonkey.  Has anyone got a fix that works in Firefox?