Wanikani Open Framework is Borked

It won’t load anymore in Firefox. In Brave, it causes the 404 Page Not Found error. All my other extensions work fine. Just started this morning.

Did you use Violentmonkey?

It’s not OF - new bug in firefox. Addons can’t be verified and getting autoblocked. They’re working on a fix, but your scripts will be broken until they roll out the update.


Then how come it causes a 404 error in Brave, which is not Firefox? I know that is the problem, because I disabled the script in Tampermonkey and the Wanikani page loaded.

No. Tampermonkey.

Ah, I didn’t read properly there. Thought you were having same problems as me.

Yet another reason why WK should not rely on user scripts too much and just integrate the ultimate timeline into WK proper already…


And the script won’t load in Safari, either. Strike 3. I don’t have Chrome.

Today Firefox was facing some issues with extension certificates (they expired). They’re saying they’re rolling out the fix right now (https://twitter.com/firefox). For me most of my extensions were (still are) disabled (not all though).


I have the same problem. Hope it will be fixed soon…


Open Framework is working fine for me in Firefox after doing a workaround for the Firefox bug mentioned above.

To fix Firefox add-ons temporarily, go to about:config , search for ‘signatures’, and toggle xpinstall.signatures.required to false .

What errors are you getting in the Javascript console? Which file is not being found? Nothing has changed in Open Framework, so it’s most likely a browser or plugin issue.

edit: also, are you installing Open Framework as an extension, or running it in a script manager?

I think that only works on nightly/dev and some linux distros. But I found a workaround script for the browser console that worked until the fix was rolled out.
Huge mistake by firefox and that just validates everybody who was against the extension signing in the first place…

It worked for me on the standard version on Android. Maybe the standard Android version uses nightly/dev??

Open Framework was installed via Tampermonkey in Firefox, Brave, and Safari.

In Firefox I get no message. The script doesn’t run and no Timeline is shown.

In Brave, the Wanikani dashboard page blinks, then I get a blank page with a 404 Page Not Found message.

In Safari, I am asked twice to if I want to install Open Framework. I just clicked the message away, as it’s already installed in Tampermonkey. Then the Wanikani Dashboard loads fine, but of course, no Timeline is shown.

I uninstalled Brave a little while ago, because it was…horrible in other ways. So any testing you want me to do will be via Firefox and Safari.

You will have to walk me through consoles, but as Firefox has other problems at the moment, maybe we should not even work with it until it’s been fixed. I have my plug-ins running temporarily, because I have work to do and that seemed to be the easiest way to get up and running again.

This did not fix it for me, nor did installing the temporary fix XPI that was floating around the Internet. I dragged and dropped all my necessary plug-ins into Firefox, so they are running in temporary developer mode.

I think so too!

1 Like

FYI—everything works in Waterfox. I forgot I had that browser installed.

Still not working in Firefox or Safari.

Now that I’m back on my PC, I downloaded Brave browser and installed TamperMonkey, Open Framework, Ultimate Timeline, and Dashboard Progress Plus. It all worked fine.

Also tried the standard version of Firefox, made sure it was the latest, and it’s working fine, too.

I don’t have a Mac, so I can’t try Safari.

I am at a loss.