Issue with scripts using Wanikani Open Framework not showing up


#1

I believe I have the WOF installed correctly and the scripts say they have been executed, but do not show up on my dashboard. Other scripts that don’t require the framework are showing up.

image

For reference, the Burn Manager, Self-Study Quiz, Lesson Hover Details, and Expected Daily reviews do not show up.
I don’t really understand how they work, so it may be a fault on my end. The developer console shows this:
image

Any help is appreciated!


#2

I’m not sure how ViolentMonkey’s dashboard works on Firefox (I user Tampermonkey on Chrome), but first thing to ask, Open Framework is the first script in the list?


#3

I’m using Tampermonkey on Firefox, but yes I have it first in my installed userscripts.


#4

I believe there was talk a while back of Tampermonkey breaking in recent versions of Firefox. Not sure if the team behind Tampermonkey ever got that straightened out or not. Violentmonkey was suggested as a replacement.
I swear there’s a few threads around here talking about it, but can’t find them now…

Wait, maybe it was just the OG GreaseMonkey that broke… nevermind


#5

A recent version of violentmonkey broke as well, and an update was pushed that’s just kind of trickling down now, or at least it was 7hrs ago.

Which I just realized doesn’t help you, because violentmonkey != tampermokey. Maybe it can help someone else though.


#6

Geez, Firefox is full of issues isn’t it


#7

You could be right, using Tampermonkey on Chrome has everything working. So at least I have it working somewhere. I did try again with Violentmonkey on Firefox and it didn’t change anything. Not sure what is wrong with Firefox, or maybe just my Firefox.


#8

It was GreaseMonkey that broke back in November, and ViolentMonkey (for Firefox) was broken the last few days, but is fixed as of ViolentMonkey v2.9.3

Just to add a datapoint to the mix here, I just tested Firefox + ViolentMonkey + Open Framework + Self-Study Quiz, and it’s working fine.

… Gotta go, got a language exchange, so I’ll be away for a bit.