Tilde was "Ro", not anymore- am I crazy?

I use Kana input for typing Japanese, because I think it’s more efficient and less of a hassle regarding the little details of romaji input. For almost a year now (maybe more), I’ve been using Kana input, and the tilde key (~) has ALWAYS been “ro”, no matter what IME settings I changed here and there. That, and “shift-caps” was the shortcut for switching from “A” to “あ” (if you know what I mean)

Literally just yesterday, magically this is not the case anymore. Now tilde is the equivalent of the “shift-caps shortcut”, and now “ro” is nowhere to be found (which is why I’m typing it as ro and not the Japanese hiragana). There is actually no button on my keyboard that can input the kana “ro”. I have no idea what spawned this change, only 2 days ago it was working just as it always had.

But that’s just the beginning- in all my research into the IME settings, and from there all my searching into answers online, it would seem as though “ro” was NEVER accessible to begin with, and the “shift-caps” shortcut never existed. Maybe 2 other people have posted a similar question in forums (although they mentioned using WIndows 7, and I’ve never used Windows 7), but every time they get an answer it’s NOT an answer. Instead, the “answer” is “have you looked into the settings for keyboard- shortcuts?” which is a complete oversight of the problem, being that “ro” is suddenly gone from IME and without explanation.

I know that kana-input is incredibly unpopular so it’s not likely that other WK members have come across the same problem, or even had the same experience with the “ro” key. But… is there anyone? Am I crazy? Have I NOT been typing “ro” with ~? Other people have mentioned using an actual Japanese keyboard where “ro” is a secondary backlash key next to “?” but there is no second key on a standard keyboard, “?” is just め. If there was a microsoft update of some kind where all this secretly changed and there’s no way of getting “ro” back, I’d certainly be quite upset, but not as upset as I am simply not knowing what the heck happened to begin with…

1 Like

Tilde works as ろ for me. Using Windows IME with Firefox, if that makes a difference.

Didn’t know about shift+capslock. Pretty sure that just changed to always katakana in the past…

I read this twice and I still don’t know what you mean.

6 Likes

disclaimer, i’ve never tried this keyboard layout, but judging from the pictures on https://en.wikipedia.org/wiki/Japanese_input_methods it seems like that “secondary backslash” is the only backslash on those boards. on my american layout that’s of course above enter. does regular backslash not work either?

edit: or could it be underscore?

for what little it’s worth, i believe you about 〜 :woman_shrugging: i don’t put it past windows in the slightest to update that sort of thing silently.

First question is, do you use a qwerty keyboard (like one sold in the US or Canada)?
Something like this?

If so, an actual Japanese keyboard has more keys than the North American Style. I have a Japanese keyboard and due to making room for extra keys, other keys are shortened to compensate. Here’s a picture. If you can see, the ろ key is located next to the right-hand shift-key.

The problem is that on North American-style QWERTY keyboard the right-hand shift key is long and subsumes the spot were the ろ key is supposed to be. The amount of keys on that corresponding row is fewer than the Japanese-style one. The North American QWERTY keyboard has 12 keys (including both of the shift keys), and the Japanese keyboard has 13 keys (including both of the shift keys).

If you don’t have the keyboard layout shown above, then I don’t know what to tell you. If you do, I still don’t know what to tell you because the spot where the ろ key is supposed to be doesn’t exist. The only think I can suggest is buy a Japanese style keyboard or go back to romaji-input because typing without being able to type ろ makes no sense.

EDIT: Even on my Japanese-style keyboard. I just tried the kana input, and I couldn’t get the ろ button to work. But it does type ろ where the tilde button should be. I do know that computer I use at work, the input style is a bit different. For example even with the alphanumeric input, I can’t type shift key + 2 to get @. It’s on the corresponding spot on the Japanese keyboard. So it sounds like the problem lies with the software drivers? I don’t know. I hope you can get to the bottom of this.

2 Likes

I have a Japanese layout Apple Magic Keyboard. Very annoyingly, while there is a setting in the macOS native IME for kana input on my MacBook’s built-in US keyboard, it doesn’t have mappings for all the kana, thereby making it useless. I know ろ is missing, I can’t remember off the top of my head if others are as well. I haven’t looked into it, but maybe there is a third-party IME with mappings for all kana on a US layout? I image you could do it by “overloading” a few more keys like with わ and を on the Japanese layout (see below). Or at least maybe there is an IME where you can customize the bindings to make it work with a US layout.

1 Like

Side note: after using the Japanese layout keyboard for a while I had to remap the caps lock key to control for when I’m using my MacBook’s built-in US keyboard. Much better use of the real estate IMO.

1 Like

Aye, it occurs to me that your ろ may have disappeared because you’ve accidentally changed your keyboard mapping from US to UK, or something like that.

1 Like

So, the ろ is indeed on the bottom right key (secondary backlash) on my keyboard.
Interestingly, when I look at the mapping, that key does not exist :confused:
It still works, though.
I have “へ” on the same key as ~

2 Likes

So, I figured out the problem and I feel like a doofus for the whole thing. After seeing this I looked into the English keyboards I have, which I hadn’t thought of before. It turns out there were three keyboards(?), English (US Keyboard), English (Japanese Keyboard), and Japanese (Microsoft IME). I recently got a new laptop, and when I had modified the IME settings to switch to Kana input (as opposed to romaji), at FIRST I actually switched the keyboard layout from English (101/102) to Japanese (106/109), which opened up the secondary English keyboard. That’s it. I had forgotten I’d done this because there’s two different places on windows where you edit keyboard settings and I had forgotten about this one when I went to look into the problem initially. ugh

The question is, why was this difficult to figure out through the internet? I have ろ back, and I’m using default IME layout. Why does no one else seem to have ~ as ろ? You’d think this’d be a reeaall simple problem to solve, but everywhere you look for information on Japanese keyboard layouts, they talk about / and \, \ being む on my keyboard, not ろ.

5 Likes

I’m also curious about that. Do you have more info about your layout (like a name or something)?
As I mentioned just above, ~ comes out as へ for me. む is actually on ] in my case.
Or… can you take a picture of your physical keyboard? (Or find one online)
Maybe it’s just a case of have keys in different positions.

Thinking that’s probably encodings again. Everyone - me included - is so used to their own keyboard layout being “normal” that it completely fails to occur to them that other countries have subtly different layouts. When I installed Windows 10, I looked at my keyboard settings in detail, and noticed that even though I’ve got Windows set to UK English, my keyboard encoding was the US version, so I set it to UK, and suddenly everything went all weird. Subtle things were different - aside from the obvious, having the £ in place of the $, several other punctuation marks had moved around, like @ and " are switched, ~ and # sit together on their own separate key which doesn’t even exist on US keyboards, and so forth. Turns out that in Australia, even though we use UK English, we use US keyboards. Go figure.

But I digress. The point is that when you post on the internet with something like “my keyboard’s gone funny”, they’re all only thinking in terms of their own keyboards, not yours. :slightly_smiling_face:

That’s the thing, I have a standard US keyboard and I’m using standard Microsoft IME settings for Kana input (on Windows 10), so it’s as standard as it’s gonna get in the US. I don’t know if you know, but the US is not a small place, hahaha. That’s why it’s odd to me that it’s hard to find someone else with ろ as ~, as far as I’m concerned ANYBODY in the US who uses Kana input (and windows 10) would have the same experience. Maybe that particular “demographic” is smaller than I think it is…

The demographic of “people who don’t use Romaji input on PCs” is minuscule in the first place.

2 Likes

Hm, I tried to look up what a US keyboard layout looks like. It’s actually quite different.
You have the ~ at the top left, then? On my keyboard (JP keyboard), it is on the top right.
The top left key is actually 全角/半角 in my case. You can see ろ at the bottom right.

Yeah, I saw this keyboard layout recently. My tilde is where the “半角/全角” is, which is why it turned into that when I had the “US (Japanese)” keyboard on, lol. My only concern knowing this now is having to get accustomed to a Japanese keyboard if I end up getting one, using ろ in the bottom right? So strange, hahaha ^^;

Actually all special characters are in different positions as well.
It took a couple days to adjust the first time, but it wasn’t that bad :man_shrugging:

The 半角 seems pretty useless these days. Half-width (Katakana) is pretty much a historical curiosity, and if you do need it, you can choose it from the IME results. I guess it might matter when typing roman characters, where you may want Full Width in running Japanese text, and Proportional “Half-Width” in longer sections of roman characters. Even then, full width roman can usually be chosen from the IME, and half-width by switching modes…
[Note: I don’t type in Japanese for a living, so perhaps natives need this feature way more than I do, and I could be blowing smoke out…]

Did you ever get a solution on how to make ` ro again?

Play around with keyboard mappings until you get the one that actually matches your keyboard.

Or, you know, use Romaji input, like pretty much everyone else. :stuck_out_tongue:

1 Like