Review item data should be loaded from tye beginning if a review

This is seriously bothering me: why isn’t the lesson data loaded from the start of a review? Very often I just give up on a review session because it gets stuck on loading when I click on the tab for more information. It’s just a little bit of text. I can’t continue with a review if it won’t even load the correct answer when I miss one. Internet connection is not always reliable but WK expects your connection to be on at all times, which is just not realistic in many places.

1 Like

Unfortunately, Wanikani cannot improve upon a normal feature/flaw of how the internet works. Just as if you were to go to, it cannot guess what news stories you would want to look at if your internet connection dropped. Wanikani is just a web-page based service.

Bummer about your poor connectivity. I’ve also been fighting poor connectivity for weeks, and since I am working from home during the pandemic, and needing massive data sets from many locations, it has also frustrated me.

1 Like

Maybe you should try the Fast Abridged Wrong/Multiple Answer script. It is designed to solve the very problem you have.

1 Like

But if you navigate to a given page on BBC, and part of the page is collapsed and not visible, you’d still expect to be able to view it by expanding if even if you lose connection. Think of a collapsed Wikipedia article on mobile.

If you are on a review item, it doesn’t need to guess which item info you might need. It’s that one.


Those also fail when my connection drops, and I end up losing the whole wiki page.

And if you submit an answer to a review without a connection, how is WK to know you answered at all?

I haven’t experienced that issue with Wikipedia. In my morning commute, there’s a tunnel where I always lose internet for about 3 minutes and I often load up a Wikipedia article in advance. Always has worked well for me, but I can’t say it’s always that way for everyone I guess.

It’s always possible to submit an answer while you have connection, lose connection, want to click info and then it won’t load… Why couldn’t it load it up before? is what he’s asking. And I’m sure it’s technically possible, but that doesn’t necessarily mean it’s what WK thinks is best for the system.

Presumably the answer is that some significant percentage of the time, people do reviews without clicking info, so it saves bandwidth to wait to load it.

If your internet connection is that bad, you might want to try the Flaming Durtles app (Android) as a workaround. You can do all your reviews and lessons offline, it just needs to connect to the internet one a month to sync and check if your subscription is still active, iirc. Something similar probably exists for iPhone.


It exists. It is called Tsurukame.


The collapsed Wikipedia article is a perfect analogy!

Yeah not sure why the ‘more info’ pane takes so long to load. Inefficient database structure/calls maybe? Could definitely use some refactoring love.

To be fair, that has nothing to do with how the internet works.

When you start a review session WK knows exactly which data needs to be sent (aka which items are up for review). At that point they could send the required extra data already, but I assume they load it dynamically to lessen the initial load or something similar.

1 Like

But why can all the audio files load fine? Shouldn’t that be more data than the info text? Also, it’s true my connection is sometimes shoddy, but if I can load the WaniKani page for the item I got wrong in a different tab (and tyen come here and complain) faster than WK itself can load the information, that is mind boggling.

Had my 52 review set rejected by WK. I really don’t feel like doing them again. Yay, time wasted.

I know it’s not just bad “bad internet connection.” Other websites work fine. It’s ridiculous that not ONCE during that long review session, my progress was not saved i.e. the system did not attempt even ONCE to communicate with the internet during thirty minutes or so, even though I browsed other sites during a break midway through the session.

I don’t have time for this: your program is broken.

Hmm? How could that happen? In my experience everything just goes one item at a time. If an item fails, nothing before that is lost.

There aren’t even more than 10 active items at any one time IIRC (meaning at the 11th item you’d have a failure if there was no connection)

Occasionally there have been times when reviews haven’t stuck for other, acute reasons, but those tend to happen without relation to connectivity and are fairly rare.

1 Like

Ehat happens is I finish the last one, then I hit next… and nothing happens (WK realizes it isn’t connected to the internet and panics). I click again, and I get the “you are not connected, please refresh WK by clicking here” thing. I click. Nothing happens. I click again. I refresh the page itself. I reset my cellular data. Finally when the website decides to reload, none of my progress was saved.

What you said about batches of 10 is necessarily false. What clearly happened is that it waits until the very end to send the results. At no point was my progress sent to the system. When I refreshed my browser, that temp data was totally wiped.

I feel like we would hear about this more often, but this is the first time I’ve heard anyone describe this. Unless I’m just misunderstanding.

To be fair, I’ve only ever used apps on mobile, so maybe there is something fundamentally different about how apps handle things and how the site in a mobile browser works.

No matter, I repeated the review (though I got everything right this time besides the expected ~4% typos—kinda defeats the purpose of SRS though because basically I cheated because I already knew the answers).

This has happened to me before. Sometimes if I wait a few minutes, WK will suddenly remember that I’ve done the reviews. Still it woukd be better if it updated in real time. And if for whatever reason the result from one item couldn’t send, it would prevent me from going on.

It does update in real time. Hmmm. You do seem to be having an unusual issue… What Leebo said about the 10 items thing is true. It’s completely baked into WK. Even Flaming Durtles does it, and it’s an unofficial app. I think this may be deeper then we’re thinking…

I guess my phone is stupid lol. I’m just using the website; no apps or anything.

Have you tried emailing the staff? Maybe they could explain what’s happening.