Problems with Niai script

I have been using the Niai user script for some time but it stopped working lately. From the Niai thread there is only little evidence that many people having this issue but I am at my wit’s end.

I verified that the Wanikani Open Framework is installed and that it is executed before the Niai script. I also added console.log statements at the end of both scripts to ensure in the console that wk is loaded before niai. In the attached screenshot you can verify the order.
I then also reinstalled Tempermonkey and re-installed only the wk and niai scripts, tried the same with Violetmonkey and tried the same with the latest Chrome and Firefox.

In the screenshot you can see that both scripts are loaded and no error is thrown but still the similar kanji section is not showing up. The displayed warnings also seam unrelated with the issue.

Does someone have an idea what else to try? Or is there simply a newer version of the plugin I missed?


Thank you for your post in the Niai script and for asking acm for help. I also linked my post in the niai thread

It doesn’t work during review sessions, but it still works on the kanji pages if that’s to any help :slight_smile:

(example) Kanji page for 緑:


Seems like it’s been almost a year since the author of the script has been online, so I’m not expecting a fix any time soon.


Thanks for the hint. When I find some time, it might be a good stating point for some debugging.

1 Like

There were a lot of changes the past few months but the biggest one required a change to the Wanikani Open Framework. Not sure if Niai uses that but it’s probably the one that affected most scripts.