Yet another "Help, my scripts stopped working!" thread

Hello, helpful people of WaniKani :durtle_hello:

I just returned to WK after taking a break for several months, and for some reason, all my userscripts have stopped working. I did not change anything in the meantime, and they were regularly updated, so I’m a little confused. I’m using Tampermonkey on Brave; it has access to WK, WaniKani Open Framework is installed and in the #1 spot. I tried deinstalling and reinstalling all the scripts, I activated Script Compatibility Mode, and I cleared the browser cache, but nothing has worked so far. And that’s about the extent of my computer skills, so I’m at a loss what to do now :sweat_smile:

1 Like

I don’t have an answer for you, just happy to realize this is possible. I installed my scripts on Firefox even though Brave is my main browser…not that it matters much since I do the majority of my reviews on my phone.

1 Like

I’m glad that my confusion had a positive effect, too! It worked flawlessly for quite some time, that’s why I have no clue what is wrong now. I prefer doing my reviews on my desktop PC, and it’s alright even without scripts, but I really miss the chance to undo my typos instead of failing everything due to “know the correct answer but can’t hit the right key for the sake of me”…

1 Like

The WK dev team started changing some things in the code of the website that broke a lot of scripts. What you can try and do is try to update your scripts (in case they’re not updated and not have recent fixes), and if that not works, you can enable “script compatibility mode” in Settings.

1 Like

I see! Maybe I just picked an unfortunate moment to return to WK :laughing: All scripts are up to date and I already tried using the compatibility mode - just tried again after clearing the browser cache, but it didn’t help. I might just have to wait it out and hope that once the code changes are done, everything will work again. And until then, I’ll have to type a little more carefully…

If it’s just the undo functionality that you want, the Double-Check script should work on the new code (compatibility mode off): [Userscript]: Double-Check (Version 2.x)

I use it and it’s working fine.

Thank you, I’ll give it a try! I use some other scripts, too, but the undo function was the most helpful (and necessary) one.

1 Like

Can you list the scripts that are not working for you?

Sorry for the late reply - timezones and stuff… I took a screenshot of my Tampermonkey list because it seems like none of them are working (I just tried again). By now, I feel like it might be an issue on my side :thinking:

First it might be good to check if Tampermonkey is injecting the userscripts. Go to a random vocabulary page and click the Tampermonkey icon to see which scripts are running. At least Pitch Info and Rendaku Information should appear in the list. If they do appear in the list, but don’t appear on the page, the console will probably contain an error message. In that case, open the console (How do I open the browser dev console?) and post a screenshot of the displayed messages.


Oddly enough, Tampermonkey doesn’t show any scripts running, so there’s definitely something off on my side. Maybe a setting that accidentally blocks something? Those are the console errors I’m getting:


So the Tampermonkey popup does not show any scripts running on the vocab page? Have you made sure that Tampermonkey is enabled?

I wonder if they’re gonna take this opportunity to change how audio playback works. It’s a pretty bad implementation that is very prone to breaking and bugging and lagging, ESPECIALLY if I install software that equalizes the sound of my pc.
My uneducated guess is that it doesn’t feed a long stream of silent audio and play the snippets during that. You know, like every single other program/website/game. So the audio software has a bit of latency to start playing the audio and WK “tells” the snippet is done before it’s actually done playing to me.

Actually that’s not uneducated it’s exactly what happens

1 Like

You know what?

…I feel stupid now, but that was exactly the problem. Sometimes it’s really the obvious things. I had never knowingly deactivated Tampermonkey, but it was deactivated for some reason, and with some clicking around in the settings, I finally got it to work again. No clue what happened there, I’m just glad my scripts are back!

Thanks for taking the time to reply and figure things out! I learned one thing today: Sometimes, it is a good idea to “turn it off and on again”…


Glad you got it sorted. Ive been invested haha


My scripts stopped working today after Firefox’s latest update. I disabled and then enabled Tampermonkey and they started working again.

1 Like