New Japanese Microsoft IME Keyboard Shortcuts?

Hi all. Apparently Microsoft updated their Japanese IME in May 2020 to a new version. Since then I’ve not been able to get the Alt+CapsLock / Ctrl+CapsLock shortcut for switching between hiragana and katakana to work. It’s was very annoying because there were some things which the prediction wouldn’t convert to katakana. I also had some trouble getting it to go into hiragana mode at all depending on the application, sometimes it seemed stuck in English mode. Did anyone else run into this, and have a solution? My workaround for now is to turn on the “Use previous version of Microsoft IME” switch in the language settings.

5 Likes

You can press F7 (before pressing space/enter) to convert everything you just typed to katakana. I always use this instead of typing in katakana mode. This assumes that the new version of the IME hasn’t changed that shortcut.

4 Likes

I had the same issue. For now I just use the old version of the IME like you.

I wrote an answer on microsoft community: Keyboard shortcuts changed in Japanese Microsoft IME in Windows 10 ver. 2004?. There are some other suggestions there too.

I also use that shortcut, and I couldn’t find a way to re-enable it (or an alternative one to use), even when skimming the Japanese documentation. Temporary solution for me was to go to japanese IME settings and select use the old version.

From the Win10 settings for me:

Time and Language -> Language (on the left) -> click Japanese, then Options -> at the bottom click “Japanese IME”, then Options -> General -> Compatibility (at the bottom) -> enable “Use previous version of the Microsoft IME”

Hope that helps someone

5 Likes

Ohhh, is THAT why Alt+CapsLock hasn’t been doing anything for me this week?

Trouble is, when I load anything for the first time, the IME comes up in Romaji output mode, and I use Alt+CapsLock to switch it to hiragana rather than move my hand to the mouse.

1 Like

I used to be a MS IME user but once I tried google, never looked back, it’s just so much faster and better. Give it a try.

1 Like

Ctrl+CapsLock still works for me, for switching from romaji to hiragana mode.

It works on the home computer for me, but not the work computer…

That’s interesting, the IME has always worked for me on my work computer, but not my home computer :sweat_smile:

I had the same issue. It somehow stopped working one day after a windows 10 update. I was frustrated at first but decided to deal with it. Now I got used to pressing space (katakana version is suggested first for words mostly written in katakana) or F7 (converts hiragana to katakana).

Not sure if you’re talking about the same thing, but I’ve always used Alt+~ to swap between the two.
I hadn’t even noticed a change :sweat_smile:

1 Like

Well, that one definitely does the trick on my home computer. Gonna have to see if that works at work too.

This really sucks :frowning:
I chose the use previous option but there’s going to be some point where we can’t do that anymore. I really hope they add the option back for these shortcuts in the new IME.

If you use Windows 10 in Japanese, the IME now supports switching between Hiragana and Katakana using CTRL + CAPSLOCK and ALT + CAPSLOCK .

This might be a sign that this is coming back, but not sure when that’ll make into a stable channel.

So that’s why that stopped working.

I found a setting to revert:

  1. In the windows search, type “Japanese IME settings”
  2. Click on “General” button
  3. At the bottom click the toggle for “Use previous version of IME”
1 Like

If you want to use the CTRL CAPS LOCK and ALTCAPS LOCK combinations then you have to not use a Japanese keyboard layout when the IME is active.

If you have a Japanese keyboard set then Windows thinks you have one of these keys and so those shortcuts would just get in the way:

Fix: Settings → Time & Language → Language

Select options for the 日本語 language pack. This is important because you have different settings for different languages!

image

Choose a non-Japanese keyboard here:

image

This is a good point and it may very well help some people who have accidentally switched the layout, but I’m fairly certain this should be the default in Windows 10 anyways. Or at least in western distributions of Windows 10.

2 Likes

Why would microsoft remove such hotkeys? I can’t seem to find any equivalent shortcut keys, only alternative methods such as using previous IME and f7.
What are they thinking up at microsoft? It must be for a good reason, right…?

Shift + CapsLock to go back to romaji.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.