Audio updates issue

Something’s wrong with the recent audio update. Sometimes, when I press “J” (to hear the word pronunciation) it plays the wrong word (the previous one?).

1 Like

Do you run any scripts?

Since the audio update, I’ve been having a hilarious bug where it indeed first plays the audio of the previous word, and then begins to layer all the words in my review session over each other, until a veritable crowd of people says a random Japanse word ever time I hit enter. Even on the meaning.

But absolutely zero problems when I disabled tamper monkey for a review session.

I haven’t bothered turning all my scripts off and then on again one by one to find the cause of the fault, but I assume it will be the same for you.

If you run zero scripts, shoot them an email at


Well if someone wants to narrow down the culprit, it’s not WaniKani Open Framework or Jitai. Since I have those two and I’m not experiencing this problem.

I also use HeatMap and Ultimate Timeline but those are not active during review sessions.

1 Like

During my next review, I’ll mess around with scripts a bit, to see if I can find the culprit.

Otherwise I feel like we’re just going to keep seeing messages of people thinking a script incompatibility is a bug introduced by the new audio update.

I just tested it in my review and turning off “Wanikani Double-Check” stopped mine from playing multiple audio’s.

1 Like

Can confirm. :+1: Also solved it for me.

Thanks for saving me the hassle of a more troublesome checking process, @jmaher16

If it is also the case that it is a script problem for you, @BoogieMan, could you then move the topic to the Third Party and API sub-forum? Since it’s then no longer a WK Feedback issue. :slight_smile:

And the amazing @rfindley has already fixed it, I find out:

@jmaher16 too


@plantron too



1 Like


It could also be this if you’re not using any scripts.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.