Audio is playing on every key press? [Solved]

Currently experiencing a bizarre bug - every single time I input a character, Wanikani plays the audio of the previous word (if it’s a vocab reading). It’s like every single keystroke is the letter ‘J’ (which replays audio). This is making it almost impossible to use with audio because I’m hearing like 10 overlayed readings of the previous word whenever I’m inputting a response. This isn’t due to a dodgy script because I’ve checked it in incognito and a different browser, and the error persists. I think it’s a local problem because I don’t have this issue on my phone and it’s started right as I reinstalled the OS on my laptop… But I have no idea what the cause could be. I don’t think it’s an issue with my keyboard because I’ve tried it with two and it doesn’t change anything. Any idea what is going on?

Super weird. I can’t check, cause my reviews are in 4 hours, but it wasn’t so 4 hours ago, when I did my reviews.

1 Like

I don’t seem to be having this issue either. Maybe the @Mods might have a suggestion if you’ve tried checking scripts, browsers etc.

1 Like

I occasionally have this other audio issue where the audio will either not play at all or just play a portion of it, it’s really weird but I figured it might be a problem with Firefox itself.

@madriano I’ve had that issue before too, but this is different. I’m pretty sure this is a local problem because I don’t think it’s a coincidence that it’s started at the same time I reinstalled my OS… But I’m not sure what could be causing it!

Do you have any scripts? If so, disable them all and see if it works correctly then.

No scripts, I get the same bug in incognito mode and another browser.

1 Like

Hmm, that’s quite strange. Hopefully someone can help you out on Monday when the WaniKani team is working, if no one figures it out before then.

1 Like

Sorry to hear that! Shoot as an email at and we can check it out

1 Like

I think I found the solution! The cause seems to have been Kaspersky Security Cloud - for some reason it appears to be affecting keyboard input. Disabling it makes the problem go away.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.