Violentmonkey scripts on Firefox no longer work


I have been having this problem for a few days now (right when I’m on holiday :expressionless:), and was wondering if other people had the same issues, or if it is just me. WKOF is not even starting, as no loading bars appear, and all other scripts seem to simply not function at all. Does someone know any way to fix this?

I don’t know if this is the same problem, but I noticed this as well

1 Like

They have been working for months, but have stopped all of a sudden. So it’s probably not java right?

EDIT: OK so all of a sudden Violentmonkey has no running scripts. I think it reinstalled itself and removed all my scripts? I had them like an hour ago. (the scripts weren’t working then as well)

EDIT2: nvm, I had “matched scripts” minimalized.
These are the scripts I’m running. None of them are showing up.

I can confirm Tampermonkey works fine (so you can switch over if Violentmonkey doesn’t work). Don’t really have anything else to contribute.

1 Like

I didnt even know tamper monkey worked on Firefox mobile. I’ll give that a go.

1 Like

When I try to install a script via grease monkey, violentmonkey jumps in the way, do you know how to remove violentmonkey?

All I can think of is disabling it from the add-ons menu:


Ah I’m an idiot, thanks.

I reinstalled everything to Tamper monkey, it still doesn’t work. :persevere: It’s really strange.

:thinking: weird indeed

1 Like

Shouldn’t open framework be at the top?

Wait, it is

You can go to dashboard and set that

1 Like

Wait, my ignore script is working, and it’s independent of WKOF if I’m correct. Then it must be a WKOF issue.