Using 12-key input for WaniKani on Android?

Hello! I’ve been using Jakeipuu on Android for my mobile WaniKani sessions and loving it (great app). But recently I’ve wanted to start using the 12-key keyboard on Android so that I don’t have to deal with my own typing issues (many missed keys).

When I use the keyboard outside of Jakeipuu it works great. But inside the app it just won’t work the way I want to. Is there a way to make it work? Do I just need to remove my 日本語 QWERTY keyboard? Do I need to switch apps? Is there an Android app that uses the 12-key?

Many thanks!

1 Like

Never used Jakeipuu, sorry. If you’re not too attached to it, you could use Flaming Durtles? I’m using a flick keyboard with that app and it works fine.

Thanks for the recommendation. I just gave Flaming Durtles a try, but when typing English it wouldn’t let me use swipe keyboard. And then with Japanese I couldn’t switch to the 12-key keyboard (same issue as Jakeipuu) :confused:

(deleted my other post since I forgot to post as a reply)

I have used SwiftKey for both Flaming Durtles and Jakeipuu with little to no configuration, switching smoothly between 12-key flip and QWERTY keyboard.

Which keyboard are you using?

1 Like

It sounds like the issue could be with the keyboard you’re using. I am using GBoard, what are you using?

I’m using GBoard. Maybe I can try SwiftKey. I’ll take a look on the Play Store

Okay, I just installed SwiftKey. The 12-key does work with Jakeipuu (hooray!), but it seems that in order to use swipe in English I have to switch back to Gboard. That would be a lot of switching in a review session. Does your SwiftKey go back to a QWERTY layout for the English? (thanks for helping out)

Edit: I found how to switch back to QWERTY within SwiftKey. But swipe still doesn’t work for me. I’ll look into this

You may have to tweak the SwiftKey settings to your liking, including installing language support for the keyboards you need.

Go to Settings > System > Language & Input > On-screen Keyboard > SwiftKey

Swipe is enabled under Typing > Gesture input > Flow

Thank you. I’ve found that this keyboard uses the word Flow instead of Swipe. But even when I have it enabled it’s not working. After looking into it, I learned that, “Flowing is not available in text fields where Microsoft SwiftKey does not offer predictions, for example password fields or the ‘to’ field of an email, or in some apps with code that clash with predictions.” This may be the problem.

@tdidriksen , do you use Flow with Jakeipuu?

Yes, for meaning input (switching to flip for reading input). Never really had any issues.
Does it work in Flaming Durtles (if you have it installed)?

I messed with some of the keyboard settings within Flaming Durtles, and that made it so that I can use Gboard with it (but crazily enough, I can’t get SwiftKey to work with it). Gboard works in Flaming Durtles with both the 12-key (for reading) and swipe (for meaning), so that’s a win.

Ideally though, I’d like to continue with Jakeipuu since I’ve grown so fond of it. However, if I can’t get it to work, I may have to switch over so that I can use the 12-key and swipe for reading and meaning respectably.

That’s interesting that you have no problem using swipe/flow with SwiftKey in Jakeipuu. Ideally I’d like to use swipe/flow and the 12-key in Jakeipuu of course.

Thanks again for your time in helping me troubleshoot this

Just had a quick look, and I think you need to enable “Word suggestion for meaning” in the Jakeipuu settings in order for swipe to work with SwiftKey.

Thanks for the suggestion. I already had that option checked. I tried unchecking, then checking again, and still no luck. I’ll have to try again with this tomorrow. Thanks again

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.