[Userscript] (Update 1.5.2: Fixed script breaking on kana vocab) Levelup material overview

Glad that worked :slight_smile:
The script did not previously replace the vanilla content, it only does now because the progress card is much narrower (and the layout is more complex).

I will likely offer both options via setting in a new version at some point.

1 Like

Please take my inputs with a bit a salt, because my dashboard is still extremely unstable. I came back after 3 months, and I am trying to get my installation of ~20 scripts back on its feet, but it is extremely unstable.

It was a very helpful pointer, because there are other scripts that remove the default progression, and I want to provide a user setting for compatibility with that :slight_smile:

An option to see official wanikani progression bar would be great!

1 Like

Version 1.2.0 now has a new setting (similar to the previous removed one):


  • Replace default progression: The script content will replace the contents of the 2/3 wide progression card next to the forecast card.

  • Dedicated card below default: The script content will create a new card (full width) below the default progression and forecast cards.

@omoide after updating, you can select the second setting and reload, then you should have the samel result as with your edit :slight_smile:


Thanks @Thalator,

I continue to observe this console error, which causes the script processing to stop:

here is the code refered by the error:

Hm, it looks like the log entry is actually one entry after the error, and not critical. Im getting the “timeago is not a function” error too after checking (looks to be from a dependency), although it does not seem to stop processing. Can you try setting the option to replace vanilla and then back again (saving and reloading between each step)? Thanks :slight_smile:

Hi @Thalanor, I’m using your r-k-v tiny bars script and it is causing a problem for me not being able to search on the dashboard, but I can search when I’m in the vocab/kanji/radical pages. I’ve checked all my other scripts and it’s definitely this one causing it.

I’m using windows 10; chrome v 80.0; tapermonkey v4.9

Just want to add that I’m glad the script is working again, and I appreciate all the work you’ve put in. Thanks

Hi, I think I found it! That would also cover (indirectly) the finding of @omoide. I had jQuery in my dependencies, but apparently I don’t need it (don’t even know why I added it at some point, must have been recently). Now both the console error (caused by this dependency) as well as the search bug is gone :slight_smile:

You can check for Updates, 1.2.2 now, is the current hotfix.

1 Like

Wow, that was fast.
Thank you, it’s working. :+1:t2:

1 Like

Update 1.3.3: A new experimental feature has been added (Recently failed items).


A “recently failed” item is an item for which you have failed to get reading or meaning (or both!) correct in its last review, and its SRS interval is still “fresh” as in, most of the time until the next review has not yet passed (configurable).

i’m personally not a big fan of the gold for burns so do you think you could add a setting to change it to the standard black

I might make colors configurable in a future update. For now, you can open up tampermonkey image and go to “Overview”, then find “Wanikani: R/K/V Tiny Bars”, go to edit image , find this:

and change both parts starting with a “#” to “#222222” (or a desired hex code) :slight_smile:

@Kumirei this is pretty cool!!
What scripts does it take to get to this?
Edit: Opps don’t worry, I see that you’ve answered already.
Obviously not just I who finds your work cool.

I like this!
Although I only show the global progression bar usually so could you make it so that the new recently failed feature can be shown without the level progression bars needing to be shown, please.

Good evening @Thalanor!

I have been using this script for awhile now and I have been free of issues. However, I seem to now be having issues with it ever since the new updates came in.

Below is an image of what it looks like when I have the script running.


I do not get the part with the recently failed items and vocab progression. Am I doing something wrong? I tried changing some of the settings but I am not very familiar with what they actually do so after trying a few and reloading to see if there is any change, I gave up and placed all the settings back to what it was before I changed it.


This above is what it looks like when I disable your script. I can’t seem to figure out what is causing it. I even tried to turn off some other scripts to see if something is hitting it but I can’t seem to make it work.

Any help you can provide will be much appreciated. Thank you!

1 Like

@YogiMaster I have redone the settings so that everything can now be individually activated or de-activated. Note (this goes for everyone) that you may need to update or reconfigure your settings, since the structure has changed.

@inspectatoro Please try again with the new settings (activate all the “show X” checkboxes that you want/need) and tell me in case that did not fix it for you :slight_smile:


Thank you for the prompt response! :slightly_smiling_face:

Thank you, I think this did the trick :wink: Below is an image of my WK page now:


It looks great, my only comment is that in the kanji progression portion, the number of kanji shown is capped (where there is a +5 in the image, apologies for the crude red arrow :sweat:). Is there any way to uncap this? And holy smokes, I did not know there is so much vocab in this level :sweat_smile: I think the vocab part is fine since there are so many so I unchecked the box. That was really handy, thank you for allowing us to change the values accordingly.

Thank you very much for sharing this script. It is great and I will continue playing around with the settings to see what will work best.

1 Like

The kanji aren’t artificially capped - the “+X” number is the number of kanji you have not unlocked yet, e.g. usually because you haven’t guru’d the radicals yet :slight_smile: The same applies to vocab. But if you want, I can look into possibly making a setting for that, too. Glad you like it!

1 Like

That’s great, thank you for doing this!
Although unfortunately something appears to be breaking down here because when I take the threshold down to either 50% or 75% of SRS then the Global progression bars disappear.
Also I still haven’t seen just the global progression bar and the recently failed only showing together but this may be due to the perculiarity that I don’t have any recently failed :wink:
Maybe this is also a reason for the Global progression bar not showing up ???

@ 75% of SRS (No bars)

@ 95% of SRS