[Unsupported] Leech training script

Is there any progress on this or can I just assume this script is dead for now?

1 Like

I never actually made any progress with it, and it mysteriously started working for me for a period so I forgot about trying to fix it. Maybe one of the more regular maintainers has some more info though.

1 Like

the script worked perfectly for me on a computer at home, but ever since I got a new laptop I’ve tried many times to get it running and I just can’t :confused:

I’m getting the empty circle too. Is there anything that can be done?

This script is no longer supported. You’ll want these 2 scripts instead:

1 Like

I’ve been using the unsupported script until the new wanikani dashboard was implemented. Now that it is gone, I came back here to discover the Self-Study Quiz has new options for quizzing leeches. It’s better than the original Leech Training script because it has customising options.

@rfindley, I can’t thank you enough for your efforts. It’s amazing work you do for us.

5 Likes

The access to this script is gone now, could this be updated?

1 Like

I’ll take a look. Hopefully have some time this weekend.

3 Likes

Give that a whirl, version 2.0 has been uploaded.

2 Likes

It’s very late in this time zone, I’ll try tomorrow :relaxed:

There’s a bug; it’ll only allow you to do one session and then it breaks. 2.1.0 coming later today, hopefully…

2 Likes

2.1.0 is released. It was also automatically close the quiz after a session.

2 Likes

Thanks @rosshendry. I thought this script was no longer supported because of the topic heading. Maybe this thread should be locked and you can start a new thread.

I confirm that the leech training script is working on Safari browser.

2 Likes

That seems sensible, no point in continuing to post in an “unsupported” thread.

New Leech Trainer! [Userscript] Leech training

4 Likes

It works perfectly! Thank you so much! Sorry for my late response. :sweat_smile:

I noticed that the api key in my local storage has the title “apiv2_key” rather than “apiKey_v2” which is referenced in this script in the get_api_key() function. It was causing an error in my console so I tracked it down to this script.

I’ve been using this script a lot recently and found it very helpful…but something seems off…or I’m making a mistake somehow…

when I get to Heart Shaped (stupid rendaku) always seem to forget after 4 months when it comes around to burn…but anyway … it won’t accept it and the entry field just bounces…

This is how I normally input to WK

Then if I deliberately type a wrong answer it does show the error:

But if you go back to the correct it still won’t proceed and bounces so I thought well let’s try katakana and hiragana and still same thing…

So it’s either somethings broken with this one particular item, the script or the idiot behind the keyboard :confused:…any one know what’s going on? how to fix?

Closing thread as it’s unsupported.

Seems like this is the new one.

3 Likes