Unlocked Radicals not showing up in lessons

Hi guys,

I just leveled up to lvl 9 and 6 of my radicals don’t show up in my lessons.
Hovering over the radical on my dash indicates it’s available, however it does not appear in my lesson queue.
As you can tell tell from the screenshot I have a reordering script installed. Disabling it did not relieve the issue.
I wasn’t sure if this was a bug or if I’m missing something.



Also, my dash indicates I have 136 new lessons. However, adding the 12 kanji and 118 vocabs gives me 130.


This looks like the bug I reported in the lessons filter thread. The radicals with only images don’t show up in the lessons filter queue.

They said disabling the script didn’t fix the issue. Also, that image with the “Radicals and Kanji first” button makes it seem like a different script anyway. That said, it could be the same issue with multiple reorder scripts, or maybe it’s an issue with vanilla WaniKani. I plan to look into the issue sometime this weekend.


This. I noticed that they were only images, too. What’s up with that?

I’m thinking it might be vanilla because disabling all scripts makes no change, unless I somehow broke vanilla by using the reorder script too liberally. :man_shrugging: The script is “WaniKani Lesson Ordering II”, if that makes any difference.

I’m wondering if I should just try contacting wanikani diractly instead of posting in the forums. The bug has already ruined my “level a week” goal. :frowning:

1 Like

Some of the radicals don’t exist in the world outside of WK. So they are not included in the Unicode charset, and WK needs to use images (instead of font characters) to display them.


On our end we see all of the level 9 radicals which use images are still in your lessons. They should be showing up in your lessons.

Do you have access to a different browser, preferably one that has zero scripts installed? I would try another browser just to see if the problem persists. If the radicals do show up, then I would try disabling all scripts (it wasn’t clear if you only disabled all scripts or just one) on your default browser and then enable them one-by-one to identify the problem script.

1 Like

Hi, thank you.

Yes, I tried disabling all scripts. I just checked my lessons using a different browser, there are still no radicles available in the queue.

1 Like

I had the same problem with WaniKani / Radical / Grass. I also use the reorder script. I managed to study it on Tsurukame however, so I did not try anything on my browser yet.

Bless you, @nikosant

I was able to do the lessons using the Jakeipuu app.
Still not sure what caused this bug’s persistence across other browsers and devices, but it seems to be solved for now

Thanks, everyone.


The app probably uses the API to determine what lessons are available, so there could still be a bug with the WaniKani website (UI) itself. I don’t think there’s any way you could have gotten vanilla WaniKani into a bad state by using scripts in one browser.

In my case the image radical (the bar radical to be precise) is seen by the lesson hover details script but not in the WK lesson dialog. So the radicals are somehow in the lessons but the WK lesson dialog can’t see them.

I am seeing this behavior on both Firefox and Chrome. I am using Windows. I have also seen the bar radical missing when no scripts are installed.

1 Like

Thanks for the info.

I am doing some digging into this now.

Specifically for the bar radical, it looks like people have been able to do lessons on it since the changes we made a couple days ago. Doing an SQL query on all bar related assignments which have been unlocked_at in the last couple days and have started_at set in the last couple days yielded results.

I am using vanilla WaniKani myself and I am seeing and interacting with the few image-based radicals in lessons just fine.

Scratching my head on this one. I’ll look into it a bit more.


It’s possible they are doing the lessons through an app which uses the API. If it’s a website problem, that wouldn’t affect apps which use the API.

Though I see you’re having no issue on the website yourself, so that certainly is strange.

1 Like

Looking at the radical stick, which is level 1, since two days ago, more than half were completed in lessons.

Maybe this is an issue with specific image based radicals…

1 Like

How about items unlocked before the change? Do they get started after the change? I think this might be my case.

1 Like

Could be. But majority of our users use vanilla. And the numbers are weighted where it wouldn’t make sense if the many of them were registered through API apps.


For future things like this, maybe you should add a field to the API write endpoints for “source” or something like that. It would be on the honor system for apps to actually fill that out and use a unique name, but if used correctly it could be useful.

1 Like

From a period of 4 days ago to 2 days ago, about 85% of the “bar” assignments that were unlocked for lessons were completed and moved into reviews. This was before the change was made on our end that cause some issues with scripts.

From a period of 2 days ago until now, 100% of the “bar” assignments unlocked for lessons were completed and move into reviews.


Could it be a caching issue with the jStorage? Have you tried in an incognito window or something like that?