The Struggle - basic WK review analysis with a graph

Do you mean it starts loading and then tells you there is an error, it might be because of your API code? Because then you are just having the same issue I posted a screenshot of above. It is not because of your API key in that case, just hitting a request limit.

@irrelephant @shoshinonryu I’ve just made a small change to show a better error message.

It seems fairly unlikely it’d hit an API rate limit for a L3 user but for L33 it’s possible. If either/both of you don’t mind sharing a token I’ll look into it tomorrow… Seems we don’t have private messaging here but you could generate a new read-only token and post it, then delete it so nobody can API-stalk you forever… (Is that a thing? Could be a thing…)

(I’m thinking I could just code in a wait/retry, as the laziest option, and see if that helps.)


My error was different than @irrelephant’s was. Whenever I’d put my API in, my browser would just reset the data so I couldn’t even input the information. But it was a browser issue… it works at home!

OK, great, glad it works now… The behaviour you experienced could maybe happen if the code can’t write to local storage or something, it’s not exactly production quality work with all the right checks in. Some kind of locked down company machine? Or the dreaded Safari?

It’s not Safari, it’s Internet Explorer (equally awful), but yes, definitely a locked down company machine lol

Aaah, IE! Yeah, that probably doesn’t support some modern JS features I used. One mystery solved.

Ah, that did it! Makes way more sense now that I don’t have hundreds of items saying I lost almost two years :joy:

And to the rest of y’all, how on Earth are your graphs so clean??? This is mine :sweat_smile:

Edit: realized I left my API key, had to go edit it out and reupload


Wow!! Thanks for procrastinating WK and making The Struggle!!! I LOVE IT!!! :smiling_face_with_three_hearts: It’s very helpful for me!

I used Chrome on my Mac. It loaded when I went out. After that, I used Safari, still on my Mac, not dare to try this on my old iPad. It didn’t load, or actually it loaded, but it’s slow on Safari. It’s still loading again after I inserted my WK API v2 there. And it also works on my Safari now. Wow!! The vocab/kanji list down there is really helpful for me killing my leeches!

Ganbatte! And! Please procrastinate more! :laughing:

Edit: I’ve just added The Struggle to The New And Improved List Of API and Third Party Apps under Browser Applications > Web Applications.


Awesome, very glad you like it! But nooo, procrastination is bad! I’m trying so hard to NOT start building a whole new SRS app. :persevere:

Thanks for adding it to that list, I don’t think I ever really looked through it properly before - some handy stuff there.


I absolutely love this page. Would it be possible to individually chose which radical/kanji/vocab item is displayed on the graph?

Whenever I try my key, it says “cannot read length of undefined.” I tried both my read only and non-read only API keys.

What should I do?

This is the most elegant thing I have seen in a while.

Also, way to take Wall of Shame to a new level… :stuck_out_tongue_winking_eye:

I had the same problem. Removing the hyphens in the API solved it.

1 Like