The Struggle - basic WK review analysis with a graph

Not sure if it is already done this way, but are you perhaps scaling the thickness of the lines linearly with the amount of lost days? You could also try to do this logarithmically, such that an increase from 50 to 100 adds as much thickness as an increase from 100 to 200, or 200 to 400. This makes the extra thickness from 50 to 400 an extra 3 units of thickness rather than having it be 8 times thicker.
Or maybe maximize the thickest possible line and connect that thickness to the highest amount of lost days.

Yeah, it is linear - though I’ve just tweaked it a bit more so the scaling varies depending on the user. Log scaling is a good idea, I may well play with that a bit - thanks.

Ah, in fact…

…is what I think I’ve done most recently. Great minds, etc.

1 Like

image

Just a little example I put too much time in.
If you assume 1 day means that the line is one pixel thick, then the blue part resembles the relative thickness in pixels for a linear relation, the red part is for a logarithmic relation.

2 Likes

Thanks! this makes me twice as pissed that I got the last review for 今日は wrong. 44 lost days :frowning:

Most demotions : useful for leeches
Time wasters: useful for getting mad :joy:

3 Likes

:sob:

3 Likes

The Struggle, indeed :sweat_smile:

4 Likes

why use cursive in popup bubbles, makes kanji confusing
Also I guess A1 column should have n/a for its success rate, can’t get lower than that.
Anyway, cool stuff, thanks for sharing!

1 Like

Laziness! I just used the defaults for that charting lib. Modified to be clearer now, thanks for pointing it out. (WK hasn’t made me learn any very complex kanji yet, so it wasn’t a problem for me.)

Also laziness, and I will remain too lazy to change that.

@Pep95 thanks for the illustration, I’ve had a play with log (and exp) functions on line width and I’ve decided I still prefer it linear, after the tweaks I made earlier.

3 Likes

I think the most painful part is seeing the total number of burns you failed… :sob:

It seems to hit a limit after around 60 requests or so. But maybe that means that I wouldn’t have wanted to see my chart anyway? :wink:

1 Like

For some reason, I’m not having any luck with it accepting my API code (using V2)

I’ll try again from my home computer later, and maybe have more success. This sounds like something I could definitely use in my struggle!

Do you mean it starts loading and then tells you there is an error, it might be because of your API code? Because then you are just having the same issue I posted a screenshot of above. It is not because of your API key in that case, just hitting a request limit.

@irrelephant @shoshinonryu I’ve just made a small change to show a better error message.

It seems fairly unlikely it’d hit an API rate limit for a L3 user but for L33 it’s possible. If either/both of you don’t mind sharing a token I’ll look into it tomorrow… Seems we don’t have private messaging here but you could generate a new read-only token and post it, then delete it so nobody can API-stalk you forever… (Is that a thing? Could be a thing…)

(I’m thinking I could just code in a wait/retry, as the laziest option, and see if that helps.)

2 Likes

My error was different than @irrelephant’s was. Whenever I’d put my API in, my browser would just reset the data so I couldn’t even input the information. But it was a browser issue… it works at home!

OK, great, glad it works now… The behaviour you experienced could maybe happen if the code can’t write to local storage or something, it’s not exactly production quality work with all the right checks in. Some kind of locked down company machine? Or the dreaded Safari?

It’s not Safari, it’s Internet Explorer (equally awful), but yes, definitely a locked down company machine lol

Aaah, IE! Yeah, that probably doesn’t support some modern JS features I used. One mystery solved.

Ah, that did it! Makes way more sense now that I don’t have hundreds of items saying I lost almost two years :joy:

And to the rest of y’all, how on Earth are your graphs so clean??? This is mine :sweat_smile:

Edit: realized I left my API key, had to go edit it out and reupload

2 Likes

Wow!! Thanks for procrastinating WK and making The Struggle!!! I LOVE IT!!! :smiling_face_with_three_hearts: It’s very helpful for me!

I used Chrome on my Mac. It loaded when I went out. After that, I used Safari, still on my Mac, not dare to try this on my old iPad. It didn’t load, or actually it loaded, but it’s slow on Safari. It’s still loading again after I inserted my WK API v2 there. And it also works on my Safari now. Wow!! The vocab/kanji list down there is really helpful for me killing my leeches!

Ganbatte! And! Please procrastinate more! :laughing:

Edit: I’ve just added The Struggle to The New And Improved List Of API and Third Party Apps under Browser Applications > Web Applications.

3 Likes

Awesome, very glad you like it! But nooo, procrastination is bad! I’m trying so hard to NOT start building a whole new SRS app. :persevere:

Thanks for adding it to that list, I don’t think I ever really looked through it properly before - some handy stuff there.

2 Likes