Set Time Zone for Review Forcast

How do we set our time zone in WaniKani?

When I look at the “Review Forecast” section, it seems to think my timezone is seven hours ahead. Like, it is currently 5:52 p.m. where I’m located, but it’s telling me that “Today” at 1 a.m. I should expect 2 more reviews. (I’m assuming it is using UTC.) I’ve looked around the account settings to change it, but if it’s there, I’m missing it.

1 Like

It’s not using UTC as a default; mine is on local time, and I didn’t have to set it to that, it was automatic.

I’m using a Windows10 PC with Chrome.

I’ve read Firefox can do some funky things with people’s WK…

1 Like

Maybe check the time on your device?

4 Likes

I agree with @raephe that usually this is a problem of your computer’s clock not matching up with your own. Could you make sure that the time zone is correct on your device?

2 Likes

Everything else seems to be aligned, so not sure where else to check for the mismatch. In the following images, the additional reviews are going to enqueue in the next hour, not at midnight.


macOS-info
time-zone-settings
firefox-info

I tried searching in the browser preferences, but I don’t see any time or time zone settings.

Do you just not have any more reviews until then? If your clocks are all fine that would be my inexperienced guess, especially as you’re at level 60. The Review Forecast doesn’t show the hours where you have no reviews. For instance, here’s what mine looks like right now, with no reviews at 10 or 11:
pic
please ignore my high review count, I’m working on it I promise

Nope, those reviews were for 5:00 p.m. my time. I finished a review session to come out with the announcement for the 53 new ones.

That answers that :sweat_smile: Hmmmm well then I don’t really know except to check everything that has some sort of clock setting on your computer? Also once I had an issue (with a different thing than WK) where because it couldn’t access my location it messed up the time, maybe it’s related to that?

Sorry I can’t help more, I hope you figure out what’s wrong!

I previously mentioned Firefox and you have confirmed that’s what you’re using - I am not tech savvy, but from what I’ve read here on the forum, Firefox has inbuilt security features that can block some of your information being shared with WK, and that may include your location / time zone.

2 Likes

If anyone comes across something that can be changed, please share. When I dug into “location” settings for Firefox, it only listed sites that had explicitly asked for location data. If WaniKani needs the data to calibrate times, then maybe it needs to explicitly prompt? Alternatively, if a value was exposed in the settings, I could set it.

The browser comment seemed to work for me. On Firefox, I have new reviews incoming:

11 pm +21 21
12 am +3 24
1 am +5 29
5 am +46 75
6 am +12 87

It is currently noon exactly where I am, so 12pm.

This is obviously wrong, and I just ignored it for a long time, but I just now opened Wani in Chrome, and here are my incoming:

1 pm +21 21
2 pm +3 24
3 pm +5 29
7 pm +46 75
8 pm +12 87

Which is obviously much more reasonable.

Have no idea why Firefox is so finicky (although, as mentioned previously, something along the lines of info sharing, something I generally like about Firefox, lol) but Chrome seems to do the trick for me.

Just wanted to share.

I’m observing the same problem in Firefox on Linux. I did some poking around in the JS console and saw that I seem to be living in a weird quantum superposition of UTC and my local timezone at the same time:

> new Date
Date Wed Jul 01 2020 13:41:08 GMT+0200 (Central European Summer Time)
> (new Date).getTimezoneOffset()
0

I guess that WK looks at getTimezoneOffset which is 0, i.e. UTC, so it shows times in that timezone instead of my local time (CEST).

1 Like

This is an 18 year old bug in Firefox

I just noticed by random chance that the correct time is displayed when I log into WK from my work computer, also using Firefox. After some more poking, the main difference is that my private PC’s Firefox has privacy.resistFingerprinting enabled, and that appears to affect the reported timezone offset as well.

So technically it’s an issue on my side, since I could choose to disable that flag, but I want to have it for obvious reasons, so I would appreciate if WK had some configuration option in the profile settings for overriding the timezone autodetection.

1 Like