Wanikani reviews not fuctioning properly reviews being half an hour late (Solved)

Before I start I have emailed support and there isn’t anything wrong on their end, and I have checked my time zone cleared my cache and restarted my devices multiple times so idk what is wrong but my reviews show up consistently 30 minutes late.

For example I would have 28 reviews scheduled for 6pm, they would not show up till 6:30pm.

If anyone has any tips that would be greatly appreciated thank you so much!!!

I have never experienced anything like this myself. Or heard of this issue before. the team can probably help you once they’re awake in Portland, US.

But, until then all I can give you are the general advice: to first disable tampermonkey if you’re running any scripts. Update everything that needs updating with your computer, browser, OS. Are there anything else affecting timekeeping on your device than the timezone? Check for this then.

(Check for updates also for any scrips and tampermonkey, but don’t turn those back on before checking if it helps = scripts are somehow to be blamed)

That’s all I can think of for now. But, yeah, the team will be awake later today and will defo help you.

Edit: also forgot to ask, you are talking about the Wanikani webpage/app, because that’s all they’re in charge of. Any phone apps are third party applications and they are not responsible for them. They’re not official WK apps. :eyes: Check the subforum for Third party applications and the specific threads for the app in question and ask for help there.

Yeah I have chatted with the team and implemented their suggestions already but it has not worked. I use the Wanikani webpage btw. I have also updated all my devices and browsers.

Other than the browser time zone and my computer settings which I have already checked what would?

Did you check your console, I guess, if they’ve already gotten back to you, then they might have asked that already.

Still, for me, since I’ve never heard of this strange 30-minute delay before (as in, I can’t remember ever seeing a thread about it before these past years), I can only suspect something on your end of things.

Maybe broaden the scope of your googling for suggestions for what may be at fault when it comes to timekeeping in general on your specific computer, is where I would go then. :eyes:

Yeah Though the time on my computer is correct and there looks to be no issue there. Thanks for the help!

1 Like

@EBBB Could you please let me know what your timezone is?

If you could run the following in the developer console and let me know the result that would be a help too.

1 Like

Sorry I couldn’t be of more help. ^^

That’s ok!

1 Like


tofugu-scottWaniKani Engineer

Ok I ran it and its said ‘Australia/Adelaide’.

My time zone is GMT+10:30 Central Australia Time-Adelaide.


Lol, that’s got to be related to the problem somehow.


I’m in daylight savings time idk if that may be affecting it?

No I’m just saying, having a fractional hour offset from GMT, 30 minutes, which is kind of unusual AND your reviews showing up exactly 30 minutes late - quite a coincidence, no?

Not that I know how to fix it, but now I’m not so sure the problem is on your side.


Yeah I have no clue what is wrong either but hey at least Wanikani is still usable albeit a little annoying with the late reviews.

@EBBB I have deployed a fix that should now show the correct forecast times for you. This is live now but might take 10 minutes for caches to clear. Could you please take a look and confirm that it is now working as you expect?



Hah, timezones. An ever-present nightmare for developers. Next up is UTC+08:45 :sweat_smile:



Thankyou so much!!! It has been fixed and my reviews for 6:30pm came at 6:30pm!!!

If you dont mind, what exactly was the issue? I just want to know for future refence incase this happens as again and I need to contact support again. Also just in case other people also run into the same issue as me.

Thank you again!!!

I didn’t know that one existed!

And yes time zones can be an absolute painnnnnnnn sometimes!!!

The issue was caused by a recent update I made. We are still in the process of moving away from React and when I migrated the code I neglected to add the minutes component (which most people outside your timezone never need or see). You should not experience this issue again as we have test coverage for this use-case now. I will also talk to customer support about this issue in order to improve our support on this matter in the future.



Hmm, trying to remember if this would have affected me. Just flew from Perth to Adelaide to Alice Springs, can’t remember when and where I did my last reviews. I’m really jet lagged…