Review forecast not respecting local time

The review forecast seems to be using UTC instead of local time. Atleast it is 1 hour behind for me. Would be nice if that could be changed.

It’s definitely not on UTC for me (that would be an 8 hour time difference, and it is correct for my locale). Have you recently switched to or from Daylight Savings?

As @Rowena mentioned, it may be due to daylight savings time, or you could check if you are using a VPN. (I don’t know how it gets the time, but I know that because you say it isn’t respecting your local time, it probably isn’t getting your local time.) Or check to make sure your computer is on the correct time.

For me (a browser user) it seems to be using the system time of my laptop.

1 Like

@Rowena no I didn’t switch to DST we are still on Wintertime here.
@zmontgo04 My system time is correct and I’m not using a VPN
@ForgottenRock I’m using firefox and it is not using my system time

The time is definitely 1h behind and matching UTC for me. The timeline was showing me I would have 5 reviews at 12pm while it already was 12pm and I had 0 reviews. I then had 5 reviews at 1pm local time.

Maybe it thinks you did switch ahead. Try googling “what’s the time”. It should show you the correct time. If it doesn’t, then it’s a local issue. If it does, then there’s something wrong with WaniKani specifically. Tell me how that goes. I think if it’s WaniKani specifically, there may be an issue with how it gets the time.

Same problem for me. It’s even more pronounced now that the “next hour” info is gone… I have to look at a wrong hour all the time.

I wish they had it as a user setting. My Firefox doesn’t seem to allow timezone information for the browser (which is a good thing).

1 Like

Hmm… this seems to be a thing with Firefox. Try a different browser. Safari or Edge, or Chrome (if you have Chrome installed I’d suggest that). If the issue does not persist, then it is a Firefox issue. If it is such, try temporarily turning off “privacy.resistFingerprinting” Link: https://support.mozilla.org/en-US/kb/firefox-protection-against-fingerprinting, and see if that fixes the issue. If it doesn’t work on other browsers, then try a different device. It may be an issue with your computer.

2 Likes

@ zmontgo04 Whats the time gives me the correct time. Chrome and Edge have the same issue. My laptop has the same issue. My smartphone also has the same issue. The library computer has the issue as well.

If all those devices are using the same wifi network, try turning it off for your phone and using your data. It may be an issue with your wifi network not allowing the server to request the timezone, or an issue with your IP address showing a different timezone than where you really are. Googling “what’s the time” would tell you the local time, so I wanted to make sure it wasn’t a local issue. But it may be a network security thing that blocks getting the timezone.

I wouldn’t encourage people to make their browser less secure/private just to fix the timezone.

1 Like

I meant temporarily to see if that was the issue. If it is, I would not suggest leaving it off, but using a different browser. Firefox blocks the timezone collecting to keep sites from fingerprinting their computer, but the technology is still very new and still in development.

1 Like

The timezone is derived from the system’s clock. First thing I would look at is to see your device’s time is matching your local time. One easy way to do this is to have your system settings automatically set your timezone using your current location.

1 Like

I’ve been happy with WK’s timezone adjustments (after my device/system adjusts). I do wonder about the WKstats site, though, which seems to be according to Pacific Time (?) [am currently in Japan)].

The stats site is third party and made by @rfindley

2 Likes

Yeah, I figured it was third party. Have enjoyed it and have greatly appreciated it. Never knew who made it!

1 Like

wkstats should also be based on your systems’ settings, I think.
But it’s been a long time since I’ve looked at it, so I could be wrong.

1 Like

I remembering it adjusting before. I think? But I’ve traveled there and back again, so my memory’s fuzzy too. Anyways, thanks for the resource. :slight_smile:

1 Like

Just wait a couple of weeks until DST and then your time will go back to the correct one.

My system clock is correct but with Firefox the timezone is wrong even with ‘privacy.resistFingerprinting’ set to False. It’s only one hour off, though, so maybe it has something fishy to do with daylight saving.

EDIT: set to True, it’s UTC.