Fixing timezones in scheduled reviews

Hello there. I recently moved to japan, but unfortunately WaniKani doesn’t seem to realise that. The timezone is still GMT, even though my system is on UTC+9. I know this is an old issue, but I was curious if anyone had a fix.

Most of what I’d see was people saying to use a different browser, which no I will not do just for WaniKani to work. It does work fine on Brave, but on my very privacy modified version of Firefox isn’t. I did try load the default firefox profile to see if that would fix it, but it did not. I’m not really sure what else I can do.

Does wanikani have time zone? I never knew that!

But you see, fixing time zone won’t change the time of reviews as it’s connected to the SRS interval and not a time zone. The only way to “fix” the review interval is doing reviews from now on on your “correct”/new chosen time. With time, they will fall in the window you want and let’s say not in the middle of the night anymore.

I should explain more clearly. The time between reviews is correct. When it says my next review is coming up is wrong. For example, my next review is at 5am today, which is impossible because it’s currently approaching 2pm. The review will happen at 2pm, but the schedule shows everything behind by 9 hours.

1 Like

It seems appropriate use of vacation mode can do the job (have a look to section 10. in My Journey of 368 days (+ The Ultimate Guide for WK 📖 ) - #2 by jprspereira). The instructions provided in this guide suggest to enable vacation mode before departure, but I think it can be adapted to your own schedule (enable vacation mode at the local time when your reviews are coming up, then disable it at the local time when you are used to do your reviews).

1 Like

I think you’re confused. There’s nothing wrong with the review times. It’s just when wanikani says they are. The actual time of the review and when it says the review is don’t match. For a review at 2pm, it will say 5am the same day. It’s 9 hours behind the time zone I’m in.


Doesn’t WK have a profile setting for this, or am I imagining things? :thinking:

Edit: Nevermind I was thinking of the one on the forums

1 Like

I’m surprised it doesn’t. It feels like a really easy one to add and one that is a great backup for timezone shenanigans like this happening.

Sounds like Firefox has the wrong timezone, and WaniKani is using whatever the browser tells it the timezone is. Seems like this is related to the privacy.resistFingerprinting setting:


That’s what I imagined, but I’d expect the default profile to not have the issue, which it still did. Maybe that one also has it on, but I doubt it. I’m hoping it’s just an issue with wanikani storing the timezone, since then I can still keep my finger print resistance on.

Edit: I checked and it is set to false, so no idea. There’s other related settings that might be messing with it, and in the settings page it says the standard settings block fingerprints, so maybe there’s so other bit, but even when setting it to custom then not blocking fingerprints I couldn’t get it to see my local time.

1 Like

Could be a cookies or cache issue? You could try WaniKani in an incognito window to see if the cache might be the problem. Or deleting cookies? I really don’t know though, I moved timezones and never had this issue.

Tried again on the default profile for firefox. I logged out on my regular profile, cleared all my history, reloaded the page, and still it won’t work on default firefox profile.

I’ve seen this before with other Firefox users. You wouldn’t see this date
as noon (or around noon) in Japan either.
I think @morteASD is a Firefox user who might know a fix?

1 Like

That shows as July 1st, 4am, correct.

1 Like

Have you tried if it works in troubleshoot mode? I can’t remember if I ever fixed this, I was also using some stricter privacy settings and they purposefully block the timezone detection. Could be that even the default settings don’t allow it nowadays.

privacy.spoof_english also broadcasts your timezone as UTC when set to 2.

Default profile has that set to 0 I’m afraid.

Troubleshoot mode also does not appear to have it work, unfortunately.

I wonder there’s either some server or local stored timezone that’s just not being updated when I try these settings? :thinking:

@Mods is this a known issue or do you know a fix for this?

From what I understand, when this has happened before it was due to the user’s specific settings so I’m afraid there isn’t much we can do.

What we suggested before was to set finger print resistance to false but I see that’s been tried already.

You may have a better chance with Firefox support.

1 Like