Security warning when trying to access wanikani on firefox

I used Wanikani just fine on firefox yesterday but now today when I tried to go to the site I instead got presented with this screen and no apparent option to ignore it. Works fine on Chrome which is how I’m posting this here.

Edit: Actually seems I can access the community part just fine, it’s just the dashboard and reviews and such that I get the error with.

It looks like something is getting redirected to some sketchy casino site, judging by the error.

I’d run a thorough virus scan if I were you.


I’ve experienced something similar when using public wifi. Usually because my free WiFi usage period has expired and it’s trying to re-direct me to the page to enter my email again to reconnect

Look at the error. The certificate claims to be for some casino site, and that doesn’t strike me as what a wifi gateway page would be.

In general, anytime you see a warning like this, you should pay attention - your browser is trying to protect you.


Oh sorry I didn’t mean to imply that this case was due to using public wifi but more because an insecure “source?” is trying to navigate away from your current page which is also often the case with wifi gateways.

When it appears to be initiated by a casino site (or any other similarly suspicious site) it’s obviously more worrying and should definitely be looked into.

Generally, anytime i see something like that while I’m on public wifi (very rarely), I close the browser and restart it. If it’s a lease renewal that’s needed it should be the first thing to come up. But, we’re getting away from the topic.

@Fleckens, You said this only happens on firefox, not chrome. Did you install any extensions or scripts into firefox since the last time the site worked for you?

No that’s the weird thing, I used it right before going to bed last night with no issues and now it’s the first thing I did on my computer here in the morning. I’ll try to delete cookies and such and restart the pc and see if that does anything.

Run a virus scan as well just for good measure. Man in the middle attacks make me leery

1 Like

Yeah I’m doing that right now, Did a quick scan just before which found nothing and restarting and deleting didn’t do nothing, nor did turning off things like greasemonkey and the scripts but running a full scan now.

Scan found nothing so I’m really not sure what the issue is. I’ve checked so many other different sites as well and It’s only here I get this error, it’s really weird.

Maybe give something like Malwarebytes a shot at it. See if you’ve picked up some kind of malware or scumware.

1 Like

Found 0 things so guess that wasn’t it either.

Well not sure what was the issue but I just came back to my pc and now it works again.

Now I just need to figure out why all my scripts are no longer working though, despite all being shown as active.

Because you turned off Greasemonkey a few posts ago? :stuck_out_tongue:

Though, I thought Greasemonkey didn’t work on Firefox any more. I’ve been using Tampermonkey.

1 Like

No I turned it back on of course(and reinstalled). That said it seems it doesn’t anymore, switched to tamper and now they work fine. Not sure how greasemonkey worked until now, but perhaps that was part of the issue.

1 Like

Greasemonkey works fine. It’s just that it doesn’t support the old API that nearly all Wanikani scripts use.

It’s also possible the there was an attack on your ISP, or some other part of the internet which resulted in you getting routed to a host that tried to impersonate websites ( in your case).
Since wanikani uses a technique that prevents insecure connections they could not downgrade your connection to an insecure one and thus failed, other websites you may have used in the meantime could potentially have been fake.
Also, if you were using a public wifi, it’s a likely source of this behaviour. I.e., the wifi might be one that’s provided with malicious intent or compromised (hacked) and you shouldn’t use it again.

PS: It’s really hard to tell from just this info what exactly happened. There’s a lot of links in the chain where things could’ve gone awry. All we can tell you for sure is that even though you wanted to visit (and correctly entered the url) you were about to visit some other website.

1 Like

I’m not on public wifi, or even on wifi for that matter, so that shouldn’t be the issue. I would also get the issue regardless of how I tried to access the site, be it from the community page here which I could access, but clicking the login would get me the error, or from history/restored tabs.

Also seems I am getting it somewhat again now, although it goes away now at least if I just refresh the page. Seems to happen if I afk during reviews.

Also while I suppose it’s not impossible and I admit I don’t know an awful lot about this topic but it doesn’t seem very likely that all the sites would be fake versions of hundreds of different sites like youtube, twitch, all kinds of wow related sites as well as a lot of different japanese sites. And of course this current page as well.

It doesn’t seem like much of an issue at least right now but I still really do wonder what it is that specifically gets half of wanikani blocked.

Edit: Oh yeah seems I also started getting random connection errors when I am doing reviews now, although it reloads in less than a second so it’s only a minor inconvenience at most, just a bit strange as I’ve never seen that before.

Those connection errors are probably the same issue as your visible problems, just hidden because they’re background requests.

It definitely sounds like something is off with your browser (assuming that it hasn’t shown itself on others). It might be worth a shot to completely remove firefox, and reinstall from a freshly downloaded copy. Call it drastic, but I’m a fan of nuclear options.

Was worth a try but unfortunately this did not seem to fix the issue either. I did however also sync firefox to my phone and try it there with both the phone’s own wifi and it connected to ours and it worked in both cases.

I also went and checked if it worked on another computer in our house connected to the same network and I did not have any issues there, so it does appear to be an issue on my computer specifically, I’m just really not sure what it could be.

Edit: Have not had any issues for a little while now, just did all my lessons without anything happening, and this is on the old firefox profile that I restored.

edit2: Still getting the error page once in a while now, haven’t had the lost connection so far though.

Edit3: Nvm also getting connection errors again, guess I’ll just use chrome for wanikani until I somehow figure out what the issue is as it’s too much of a pain with all these interuptions.