Chrome Certificate errors on wanikani

Hello,

Can someone confirm what is the legitimate certificate presented by https://www.wanikani.com ? Chrome today started giving me NET::ERR_CERT_COMMON_NAME_INVALID and preventing me from accessing the site due to incorrect certificate.

Checking the certificate, I see it’s issued to gauat.espmax.com instead of wanikani. Can some staff check this out?

However, SSL Checker this reports the correct certificate. I’ve never had this before

According to Firefox, the certificate was issued to the Common Name www.wanikani.com by Let’s Encrypt and is valid through 14.4.2021, 01:34:52 (CET).

Maybe you’re behind a proxy that is interfering with the certificate?

Full cert chain:

i shouldn’t be…

I’m sure you’ve already considered this but are you using any userscripts?

Are you on your own, private computer?

Yes…

And I’m not behind any proxies. I might have been pwned but im not sure I understand the angle of attack here

Many of them, yeah. But can they middleman the certificate like that? The site is not even loading so I doubt the userscripts even have a chance to execute

I don’t know enough to say, but try disabling them all and refreshing just as a check?

Have you tried disabling Greasemonkey / Tampermonkey / whatever the Chrome equivalent is? There should be a toggle that turns off the entire extension so you don’t have to uninstall and reinstall all your user scripts.

(But tbh I’d be surprised if that’s the problem.)

1 Like

I just disabled it, no difference.

One more thing to check: Is your system time correct? I have seen that error when my computer time was different

1 Like

That could result in a warning about the cert being invalid, but not in a warning about the cert being issued to a different domain entirely.

1 Like

the serial number of the incorrect certificate i see is:

0c5a5bda0b78e76e7f5c7ca47a107dc2

I restarted my PC and it fixed it, but this was weird as F…

2 Likes

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.