Can't access WaniKani on computer

I’m not very tech savvy, so sorry if this is a stupid topic. Also sorry for the wall of text but I’m pretty frustrated rn :sweat: For months, maybe even more than a year by now(?), I’ve been unable to use the WaniKani website on my computer. I usually use Chrome, and currently WaniKani is completely blocked for me by a “Your connection is not private” NET::ERR_CERT_DATE_INVALID screen. It does this for a lot of websites (and I mean, like 50%+ of the websites I try to access…), but Quora and WaniKani are the only two I can’t simply bypass by clicking “advanced”.

Because WaniKani ‘works’ (I’ll elaborate on ‘works’ in a minute) in incognito mode, Chrome claims it’s a problem with one of my extensions, and that I should turn them off. So I did. It makes absolutely no difference.

While I can just use another browser, such as Brave or Edge, or incognito mode to use the main part of the website (although interestingly Quora is still totally blocked), I still can’t access the forums? The log in page appears as a basic text page and then when I try to log in the page is just white. I can only access the forums on my phone no matter what I do. I’ve been tolerating this error because I can usually bypass it but I’ve restarted WaniKani for my new year’s resolution and not being able to access the forums at all on my computer is ridiculous ㅜㅜ

I’m aware this error is usually to do with websites not renewing their certificate, but considering it’s happening to me with sooo many websites (and big ones at that) over such a long period, I take it it’s some issue on my end? But I can’t find any solutions that have worked for me, so I’m wondering since WaniKani was a special case if anyone else who uses WaniKani has had this problem and has some kind of solution? ㅜㅜ

TL;DR How to fix NET::ERR_CERT_DATE_INVALID error when it isn’t acc a problem with the website?

no issues for me on firefox and i checked through chrome and it was fine so this may be something on your end. sounds like from the little research i did there are several local causes that can be a problem. everything from your wifi being public to antivirus settings and browser settings. unfortunately no single answers to this issue. in theory you can ignore the warning by hitting advanced and going to site anyhow, might see if you can access the site after that and if so, then it may be browser/antivirus, if still unable that might point you towards wifi/internet issues.

1 Like

While I can’t help you directly, I found a page that lists a couple of options you could try: How To Fix NET::ERR_CERT_DATE_INVALID Error On Google Chrome - Comodo SSL Resources

You can immediately jump to the section labeled “Troubleshooting issues with your computer” because it’s an issue on your end, not on WK’s end.

HTH!

1 Like

Oh this is the same website I was just looking at haha. Unfortunately nothing there has worked but thanks for trying. Although I haven’t tried uninstalling Google Chrome yet, since it’s affecting other browsers too it must be something to do with the computer as a whole…ㅜㅜ

1 Like

As I said in my post, usually I can just click advanced but this only works for WaniKani in incognito mode, but even then I still can’t access the forum ㅜㅜ I also had this problem before I moved house, so I don’t think it’s my connection either. It must be something to do with my computer but idk what to do at this point besides doing a whole refresh or something but that’s such a huge pain to go through just to get two websites to work ㅜㅜ

Do you happen to be using a work or school computer? Those often have web filter extensions for browsers that block certain websites. On my work laptop, if I connect to sites like Reddit or Twitter, I get that same certificate warning you get, and if I manage to bypass it, it shows me a “This website is restricted” blank page.

Another thing to check is if your computer’s time and date are correct. System time is used to validate SSL certificates, so if the system has a different date set up than the server, it can cause the certificate validation to fail.

Other than that I really don’t have any idea what it can be. Maybe you can try uninstalling Chrome with something like Revo Uninstaller, and then reinstalling it from zero and see if it works.

2 Likes

When you look at the details of the certificate for wanikani.com, what is the expiration/“not valid after” date?

Edit: It looks like Chrome changed the error messages since the Comodo guide was written. This is what to do on the latest version of Chrome.

If you want to get the exact date it’s more complicated now.

For wanikani.com, it should look like this:

1 Like

hmmm… So working from biggest to smallest:

  1. It sounds like it’s not coming from the WK server since the rest of us aren’t having this problem.
  2. Next, is it the computer that’s the cause of the problem? - you could try accessing the same sites by trying a couple other browsers (Firefox, Safari, Explorer, etc). If the other browsers are having similar problems then we can check out your PC / internet connection / ISP.
  3. Works okay on the other browsers? And if you still have your heart set on still using Chrome, then we should look at disabling all of your extensions / plugins / cached data / any other non standard setup that could have caused the failure.

I’m going to assume you’ve tried some combination of these already, but if there are any you haven’t tried yet let us know if you need a hand stepping through them. :hugs:

1 Like

If it’s not an antivirus, security, or ad-blocking plugin causing the problem (which would be a sign of a poorly written plug-in, in my opinion), this sounds to me like your browser could be compromised. I would suggest reinstalling Chrome as @jneapan suggested.

2 Likes

Hi everyone, thanks for all your help and advice! From @malpleno’s comment I was able to find out that the date for my certificate expiring was the same as the date I’d seen mentioned in a previous article for people using older apple models. While my computer is neither a mac nor particularly old, from there I found this article DST Root CA X3 Expiry - Invalid Certificate Error on Chrome [Fix] - Techglimpse and was able to fix the problem!

It’s a little strange though, it says the certificate didn’t run out until Sept 2021, but I was having this problem even before I moved, and I moved back in March 2021…

But for now I’m happy to leave it as one of life’s great mysteries! Thanks again for all your help, I really appreciate it! I can finally access the forum on my computer and abuse my WaniKani scripts all over again <3

1 Like

Interesting that it turned out to be a Windows Update issue.

I am on computer