[Script] Filter out forum categories (aka book club threads)

After basically getting a “no” for this:
https://community.wanikani.com/t/make-reading-its-own-section/52633

I have assembled an extremely basic script for filtering out forum threads based on category.

By default removes the Japanese Language: Reading subsection (the book club section).

Requires Tampermonkey for chrome/firefox

Features:

  • Wipe topics from certain categories off the earth.
  • Modifiable with extremely basic programming knowledge
  • Disables itself when visiting a specific subsection that’s filtered out

To modify:

  • Open up the script with tampermonkey.
  • Seach for defaultFilters
  • Remove the comments on different section or write your own CSS selector

First user script so pretty bare-bones but yeah maybe it’ll be useful. And if anyone else wants to fork and do a less crappy job (as in, add a GUI or something) then be my guest.

5 Likes

Why not just mute the reading section? It’s built into Discourse.

BTW this should probably be in the WK → API/3rd party section. :slight_smile:

4 Likes
  1. Didn’t know that was a feature.
  2. Seems like they still appear even while muted while browsing the Japanese Language - WaniKani Community section

Yeah that does seem more appropriate.

1 Like

FYI, I’m pretty sure this is a bug with the “Reading” subcategory. Muting any other subcategory properly removes its topics from its category’s Latest page (so long as the topic isn’t set to “watching” or “tracking”). I’m currently in contact with the Discourse devs to get this sorted out. I’ll let you know if they are able to fix it.

2 Likes

Thanks for doing that :+1:

1 Like

Really? :thinking: Seems to work fine for me. Of course I do see a few threads I have read through, but all else are hidden.

Cool, I was wondering if there was something user-specific going on. Funny that it’s happening to both me and @Raionus though. I wonder why.

1 Like

@Raionus Just to update you, there was apparently a bug with my user’s data that stopped me from muting the Reading subcategory in my settings. They fixed my user’s bad data and I was able to mute the Reading subcategory again. However, when I asked them to check your user, they said you had already successfully muted the Reading subcategory.

So are you sure that the Reading topics don’t properly get filtered out of Latest for you? Keep in mind that any Reading topic you are Watching or Tracking will still show up in Latest even if you mute the subcategory. But anything else (including all new topics) should be hidden automatically.

1 Like

I think I misunderstood the original point of the mute.
So this is intended, correct?

  1. Go to reading, mute section
  2. Nothing from the “reading” subsection should appear in the latest feed (as in this page specifically https://community.wanikani.com/)

If that’s the intended behavior, that is how it works and there is no bug.

I assumed it would also hide threads within Japanese Language - WaniKani Community which is currently not the case (this is the only page on the forum that I visit, since I’m level 60 and don’t really read the campfire).

So yeah, mute does what it was supposed to and my script also does what it’s supposed to.

Yes, and also this view of Latest: WaniKani Community

It is supposed to hide them on this page as well. This is working for me, so it’s odd if it’s not working for you. You’re 100% sure you’re not just seeing Reading topics that you’re Watching/Tracking?

1 Like

Okay this is the issue. There’s a bunch of things that are tracked because I posted in them like once a couple years ago

2 Likes