Request: Disable Romaji entry option

I use a hiragana keyboard on my Mac to enter readings and sometimes I don’t catch that it hasn’t switched from US to hiragana and end up typinging complete garbage. And… sometime I don’t look before my excited little fingers double-hit enter and get a wrong answer. I’d love an option to turn off the auto romaji->hiragana conversion.

2 Likes

This can help with the typos: [Userscript]: Double-Check (Version 2.x)

2 Likes

When WaniKani is auto-converting everything to hiragana, it’s because it wants the answer in hiragana. If you could turn off the hiragana conversion, every time you tried to enter a reading, WaniKani would just look at you blankly and go “… what?”

So yeah, what you want is not disabling the hiragana, but rather you need to make sure you keep an eye on whether it’s asking for meaning or reading.

7 Likes

What I want is an option to turn off romaji parsing in the reading field, because I’m intending to type in hiragana directly in that field.

I’m using this script and it helps a lot, thanks for giving me the pointer!

1 Like

Unless they’re on their phones, even native Japanese speakers use romaji entry. WaniKani doing the conversion automatically just means you don’t need to switch to your IME all the time.

I don’t believe there’s a way to turn it off, even with a script.

2 Likes