Help! My keyboard keeps typing kana instead of romaji letters

Both the keyboard on my phone and the keyboard on my laptop type hiragana when I want to, for example, answer vocabulary questions. Sometimes it turns off and sometimes it turns on. Does anyone know what to do?

Are you sure it’s not a vocabulary reading question you are trying to answer, therefore automatically turning to kana?


It could also be that you are using a japanese keyboard on your phone and you forgot to switch it back

I just had this happen too. Vocabs coming up that have the On reading and for some reason my input switches to katakana, which wouldn’t be a problem, but WK takes any answer in katakana as wrong, even if it’s correct. So what’s going on here? How do I disable that?

The built-in IME converts to katakana if upper-case is used - is your device auto-capitalising the first letter?


Not that i know. It also just started doing that now which really annoys me during reviews. Is there a setting or some su only?h that makes sure the input stays hiragana?

Edit: Found the issue. Somehow I had a script installed that would automatically turn on reading into Katakana within WaniKani.

Thank you!!!
This was driving me insane - every time I had to enter a word reading started from a vowel it turned into a katakana character instead of hiragana. Many mistakes were made in such a way.

1 Like

Hey @Nederlandsekanji! Are you still having this issue when you are trying to type in the meaning for a vocabulary word? If you are, feel free to reach out to us at and we can also continue the conversation there and get some more information about your set up!

-Nick at WK

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.