(Obsolete) [UserScript] WaniKani Double Check

:point_right: [2.0.11] - Fix response to bad input (empty answer, non-ascii in English, ascii in Japanese)

This also fixes the duplicate SRS notification at the end of the session.

2 Likes

Hey! I’m doing my reviews and when I type in an answer, the bar doesn’t change to red or green, it just goes on to the next item. I can only figure whether I got it right by checking the percentage on the upper screen. Besides, because the next item is already displayed right after I typed an answer, I don’t have enough time to click on “Item Info”. So, even if I can guess that my answer was wrong, I can’t check the correct answer on the spot.
It goes back to normal when I deactivate this script.

1 Like

I’m having the same issue :o :frowning:

I’m also having this issue. Interestingly, if you click the right arrow, it reloads the whole page.

1 Like

We updated our javascript. The update changed how we reject invalid inputs (when to “shake”). This probably broke Double Check.

Before:

  • Reading answers: any ASCII detection will shake

After:

  • Reading answers: any character not cjk punctuation, hiragana, katakana, zenkaku present will shake
3 Likes

@viet I know this has been brought up before because of the fragility of this script, but do you guys have any near-term plans to add this type of Double Check functionality of even just a way to demote items outside of reviews? By near-term I guess I’m wondering if it’s on like a 3-6 month roadmap or anything like that.

1 Like

I turned on vacation mode until we can get a fix.

I’ll take a look tonight. Double Check relies on WK’s “answerChecker” to report what it thinks is good/bad/close/invalid.

5 Likes

You’re awesome. Thanks for all you do with this plug-in!

:point_right: [v2.0.12] - Fix answer checking after WK update

@Vanilla,
I tested this with spaces before and after readings and meanings, and it worked fine. Interestingly, I don’t think I’m actually stripping the spaces in my code, so it appears to be doing it in either WK’s code, or in Wanakana, which is the IME they use.

@Matsunaga @conan @NihongoWaBenkyot @seanblue

8 Likes

Works like a charm, tyvm <3

2 Likes

You’re amazing (and your scripts as well). Thanks a lot :v:

I’m having an issue. Suddenly now when I hit enter if it’s correct, it goes automatically to the next item without any delay. This is the only script I use that manages delays and double-checking, so I suspect this one is making it do this.

I checked the settings. delay_period: 1500, It’s ok.

Something wrong?

[EDIT] This is definitely a new error. I disabled this script, and now it works perfectly. @rfindley I think you made this script, so I ping you!

1 Like

seconding, additionally, it doesn’t display the green vs. red cues. only started happening yesterday for me, was trying to figure out which script it would be, looks like this is it

@ludera @l0st,
Wanikani made a change yesterday that started causing the issue you’re describing with this script. Did you install the fix that I uploaded last night? (see about 5 posts above)

1 Like

Thank you!

It’s updated automatically. I had the last version (2.0.12?) but I downgraded it to 2.0.11 and fixed it.

But now today happened again, so they changed something else again… because it doesn’t work with 2.0.11 either (I used it today like 8 hours before and worked. Not it doesn’t…).

So I’m upgrading up to 2.0.12 again! But I don’t know if it’s going to work…let me try

Ok. Seems like now with 2.0.12 is working right. … this is dark magic. Whatever. It’s fixed, they did something that fixed it once again somehow… ?..thanks!

1 Like

meant to reply to this earlier - i’ll download the fix, that must be it. didn’t notice the update

@rfindley having an issue where moving to the next item with this script turned on cuts off the audio readings for vocab, and since I’m using lightning mode with it, I never hear the audio. which is disappointing, I’ve got autoplay audio turned on bc i find it really helps reinforce the readings in my head.

I’ve been turning this script on and off bc I can’t decide between having double check or vocab audio - anyone got an alternative, at least until this one gets a fix?