New bug - "you're quite the explorer, aren't you"

After finishing a set of reviews, I’ll see “oh there’s one more” which is unexpected (i.e. it’s not just past the top of the hour). When I click on it, I just get the message “you’re quite the explorer, aren’t you” and the so-called review item disappears.


Yes, I’ve also encountered this one. Seems to be a kind of lag with the server registering the finished review session?

@Mods tagging you to see if there’s something you know about this.


This happened to me today too!!


came to the forum today just to see if someone else was talking about this. it’s been driving me crazy for the past few days :sweat_smile: this and the lag at the start of the review session that means that my first answer every review isn’t counted and i have to retype it. i know my internet is slow, but still…


Hey @ekg! Thanks for the ping. We have an existing ticket for this issue, but it would be great to get more information.

@Digital_Larry Would you mind sending an email to so we can discuss the issue further? If anyone else is experiencing this issue, please also reach out and quickly describe what is happening and then let us know what browser and OS (and version) that you are using, so we can add your information to the existing ticket.

-Nick at WK


That’s not a review item – it’s a durtle that wanted to say hi to you :durtle_cat:


Another place this happens specifically is when trying to get to reviews from the forum when you don’t have reviews. This used to take you to a page before reviews, but now since it takes you straight to reviews, if you don’t have reviews, it can’t take you anywhere.


Just had something similar, after finishing reviews I had another 3 on the dashboard (15 minutes past the hour) so I clicked on them and got a repeat of my last 2 (not 3) reviews.

This is happening to me too. Every time I finish my reviews and go back to the main screen it’s showing 1 review still outstanding. If I click on it I the screen refreshes with reviews back to zero and I get the “you’re quite the explorer” message at the top. If I just refresh the browser after the reviews have finished the 1 disappears back to 0 and there’s no message.

I did think it might be connected to a userscript I have running but I’ve not tried with them disabled to be honest.

Its probably the default message if you access something that isnt supposed to be accessible in the GUI (lke reviews if you are at 0). @WaniConti My theory is that since there is no summary page anymore, “done” reviews are only known to WK when they get marked as done after getting reading + meaning correct, but for the last item in the review queue, since WK goes to the dashboard immediately instead of the summary page, the information about the last item being completed doesnt reach the frontend at the time of the dashboard page load immediately following the review (maybe because async). When you refresh the page from there on though, all that information is available to the frontend and you will correctly see the 0. But clicking the “1” without refreshing first will attempt to open up a review session, at which point WK notices you have 0 reviews, so it gives you the “error” message.

If I open up chrome devtools “network” tab right before completing a review, the first item in the list will be “dashboard” so that would sorta make sense for me.


Hey Thalanor! Thanks for the ping! I’ve added your comments to the GitHub ticket for the engineers to take a look at! I really appreciate you taking the time to write this out! Means a lot!! :slightly_smiling_face:

-Nick at WK


Same for me (Firefox 111.0.1 on macOS Monterey 12.6.3; using Double Check, Reorder Omega and Open Framework scripts under ViolentMonkey add-on): finished my reviews, but the main screen said I still had one. Clicked to check that one, got the “you’re quite…” error with 0 reviews.

I’ve been getting the same error. Was instructed to try in an incognito window / no scripts running, and that did not prompt the error (ghost review).

So maybe it’s a userscript issue?

Here are the plugins I’m using with Tampermonkey.

|WaniKani Dashboard Level Progress Detail|1.2.1|
|Wanikani Double-Check|3.0.14|
|Wanikani Niai Similar Kanji|1.3.19|
|Wanikani Open Framework|1.1.0|
|WaniKani Open Framework Additional Filters|1.3.1|
|WaniKani Review Item Delay|0.1.0|
|WaniKani script to disable timeout|0.1|
|Wanikani Self-Study Quiz|3.0.37|
|Wanikani: Fast Vocab Breakdown||

I disabled these ones and the problem went away. I can probably narrow it down. Also, just refreshing when you see the “1” review makes it go away.

WaniKani Dashboard Level Progress Detail
Wanikani Double-Check
Wanikani Niai Similar Kanji
Wanikani Self-Study Quiz
Wanikani: Fast Vocab Breakdown

We are both using DoubleCheck. I’ll see if perhaps that’s the one.

OK I turned DoubleCheck off after enabling these ones, then doing a review:

Wanikani Open Framework
WaniKani Open Framework Additional Filters
WaniKani Review Item Delay
WaniKani script to disable timeout
WaniKani Dashboard Level Progress Detail
Wanikani Niai Similar Kanji

and the problem still isn’t there. I’ll turn that one back on for the next review.


All right I think it’s the Double Check user script, whatever that does. Also like I said if you refresh on 1 then the count goes to 0.


1 Like

It’s not, I’ve already had a few mails going back and forth with the WK team about it. It does happen without double check. (or any other script for that matter)

If you don’t have double check enabled, you will have to quickly press enter twice to accept the answer and immediately go back to the dashboard. This is why it’s so prevalent with it. It’s quite easy to test, when you review, before doing the last one, turn off your scripts and refresh. If you then do the quick double enter to submit the last review, sometimes it will pop up.

Omoshiroi desu ne!

Am I the only one who thought this was an April Fool’s prank that carried on a little too long?

1 Like