Help with Scripts please

So, all of a sudden all scripts I’m using for WaniKani don’t work anymore… any idea’s how and why ? I haven’t got a clue haha…
I’m using Tampermonky extention in Safari on my Macbook.

Just did my reviews with all scripts… but now it doesn’t work anymore.

Thanks for the help.

1 Like

Are you also using Safari 14? On my Macbook Pro and I’ve had to disable the Semantic-Phonetic Composition userscript because it seems to interfere with the other userscripts I have installed. Unfortunately in my case, the console doesn’t log any errors things just silently fail.


First thing I would recommend is turn off each script, 1 by 1, to see if any one of them might be causing the issue.

Next, uninstall Tampermonkey and reinstall the scripts 1 by 1.

You could also install Chrome or Microsoft Edge, then TamperMonkey on there and install each script again 1 by 1, but that is entirely up to you.

1 Like

I’m on Chrome and after one of the latest updates, I lost all my scripts, too. I’ve tried reinstalling and anything else I can think to do, but to no avail. Any other ideas?

1 Like


I have no Idea what caused this all… but somehow It works again after updating my macbook. I didn’t instal the safari 14 version tho. Perhaps Updating your computer does the trick. Thanks for helping out ^^

I have had that issue with Microsoft Edge canary.

Verify you have the latest version of the WaniKani Open Framework.

My recommendation is the same after that. Uninstall all scripts and TamperMonkey. Restart the browser. Install TamperMonkey then install each script one by one and see if they work.

If it still doesn’t work, download Microsoft Edge, install TamperMonkey, install the WK Open Framework and one by one install the scripts you want to use and verify after each install it all still works properly.


I will try this, as I’ve done the others and they didn’t work. Thanks for the suggestion!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.