Mobile user problem

OK, I don’t know if this has been posted before, but can you guys please remove katakana completely.
I mostly use wanikani on my Mac, but sometimes I also use it on my phone. And my phone has auto-capitalization on (it’s useful sometimes, so don’t I want to turn it off) and if it’s capitalized, then it somehow writes katakana? Why? Since I don’t believe it will be used at all, just remove the function, or also mark the katakana writing as right. Kaniwani did it, but Wanikani didn’t?

Uh … sorry dude, if you don’t wanna type in katakana you just have to turn off auto-capitalization when you’re doing reviews. Or maybe there’s a script for it? I dunno I find it unlikely they would change that. (Also, there are a few words with katakana in there but iirc they accept hiragana too.) I don’t use Kaniwani but all the other Japanese keyboards I use do that too ;>.>


Maybe they could make an option, but I don’t see them taking the nuclear option for a single case.

The more common Japanese input methods on various operating systems automatically generate katakana when Caps Lock is on. This has just become a convention, as it’s easier than hitting F7 or the equivalent for each word when you want to type a few words in katakana but the rest in hiragana.

1 Like

That’s not WK’s fault. My phone has auto-capitalization enabled, but it’s not active in WK reviews or google search input.

I believe WaniKani has the review input set to never autocapitalize. This is why most users don’t have this problem. Unfortunately, some mobile keyboards ignore this input setting and autocapitalize anyway. I’d recommend reporting it to the keyboard/phone maker that you are using.


Chiming in here as Kitsun has had similar reports in the past:

It’s mostly an issue with Swiftkey as that particular keyboard loves to ignore the auto-capitalization rule set on the input field. It’s been an issue for a long time and they still haven’t fixed it. Perhaps disable your auto-capitalization feature or switch to a different keyboard during reviews.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.