Lessons not working

  • When I enter an English meaning (e.g. 花 = flowers) it resets me back to the review of new words (e.g. link it sends me to is: WaniKani — Log in)
  • Whenever I correctly enter a Japanese word (e.g. 花 = はな), it asks me for the kunyomi instead of the onyomi even though it is the same answer it is looking for.
2 Likes

Hello and welcome to the forum!

Do you have multiple windows of WK open?
Are you using any scripts?
What browser are you using?

(I’ve just completed my lessons without issue, so I’m thinking it is not vanilla WK causing your issue).

2 Likes


image

Just one window of WK open. These are my scripts. Using Google Chrome. Reviews work fine, but lessons always produce this same error.

1 Like

I’m also using Chrome, but you have a couple of scripts that I don’t.

I’m no expert, so I hope someone more knowledgeable will happen upon your thread, but I’m under the impression that WaniKani Open Framework needs to be at the top of your list so that it loads before the others to ensure scripts work properly.

It might be an idea to check the threads for each script to check if the issues you’re encountering have been experienced by others and they have a fix.

Are you using a Japanese IME for your lessons, or is all your input from an English keyboard?

Have you tried turning all your scripts off and then turning only one of each back on to see which script might be causing the problem?

1 Like

I’ve just seen this thread [ Review toolbar is broken ] , and seeing that you have a hiragana button to the left of the item info (eyeball) button, I’m guessing you might be having a similar issue in your lessons to what these folks were having in their reviews (not sure why you’ve not had a problem with your review and why I’ve not had any issues at all :person_shrugging:

Katakana Madness has caused this issue in the past. I would try disabling that one and see if it works. If you still want to use the script, check the thread for it to see if there is an updated version, or if anyone has posted a fix that eliminates this problem.

4 Likes

WaniKani Open Framework is already number 1 on that list, so that should be okay. That list is sorted by name.

2 Likes

Just went back and saw that it’s got a big, fat ‘1’ next to it :eyes: :woman_facepalming:

1 Like

Thanks all for the replies.

I turned off the Katakana script and it is working as normal now. Is there a way to ping the creator of that script here? Or perhaps is the Katakana script somehow interfering with the tool bar not working recently?

Thanks again all.

1 Like

It would be better if you popped a comment into the thread for the script so everyone using it knows.

Glad everything is working smoothly for you now. :smile: