Wanikani lessons suddenly broken, no idea why?

Hello,

So, since yesterday, I am unable to progress through lesson quizzes as they won’t accept either the reading or meaning of words.

I haven’t really added or modified any scripts that I run, so I have no idea what might have caused this.

Any help would be greatly appreciated.


EDIT: So I’ve determined it’s one of the scripts. Now I need to troubleshoot which.

Scripts can get broken by changes elsewhere. Try turning them all off and then testing the behavior as you turn them back on one by one.

4 Likes

This has happened to me a few times as well. Have you tried exiting the lessons, closing ALL your WK tabs and restarting your browser? It usually fixes it for me. ^^

1 Like

Yes, but I’ve determined it is the Katakana Madness script.

I guess I’ll just keep it disabled for lessons for now and re-enable for reviews.

Happy to have found out the reason; maybe it’ll help others. Seems like something behind the scenes that was updated that broke it.

To clarify, restarting Chrome or WK hasn’t seemed to fix it, so disabling is the only solution I have atm.

1 Like