[iOS/Android/Windows] Jakeipuu

I just downloaded this app and I have a problem when trying to do reviews. It lets me enter the answer for the first item, but when I press the arrow to progress to the next item I get an error message “Unauthorized. Please grant API Token permission.”
I input my API when I logged in and it seemed to work so I’m not sure what I did wrong? I’m currently unable to progress beyond the first review item, the only way to get around the error message is to quit the app.
Any insight into how to fix the problem would be greatly appreciated.

1 Like

I tried to use this app for a while, but always had the same issue. Never could use it, and now that it seems it’s not going to work on iOS I guess I’ll stick with Tsurukame for now (though I was really hopeful about Jakeipuu…)

1 Like

Interesting, I wonder why that is. I’m using an Android phone and I didn’t see anyone else with the same problem when I scanned the thread. Disappointing for me because I love the way this app let’s you organize reviews. I guess I’ll check out alternatives for now :sweat_smile:

One way I could see Apple’s argumentation is that Wanikani itself has a premium feature (subscription), that you can buy outside of the app and which improves the app.
That may not sound convincing, but if Wanikani (Tofugu) itself offered the app, it absolutely would be, so it’s not far from that.
But as esutasan said, Apple can be random in their review process (we’ve had basically the same app version rejected and passed on different reviews), and appealing/contacting them can work in some cases.

Curious, did you log in with username/password or with API Token? If with username/password, I’d recommend trying with the API Token. When you create the API Token in your account section, I think you’ll need to make sure all of the items are checked

So I just found this app and as far as I can see there is no way to force having both the reading and meaning of any item back to back in the review? I am so used to it that it would unfortunately be a no-go for me to use the app. Hope I am missing this option somehow, or you can possibly add it?
I like the design of the app other than that.
Also I didnt’t get “size” of reviews, like I always do all that are available, so that should be at least be an option?

I’m on iOS, just wanted to say thank you to @Pakkapao for making the app. I love the “let me just do 10 reviews real quick” especially. I hope you see this. I don’t know why it was rejected, but I understand if you don’t go back to it. Thanks again!

I love this app @Pakkapao ! With this, I am able to do reviews between all the sidequests in my RPGs and it’s been perfect. My favorite feature by far is how you can reenter an answer(my phone typing skills are terrible).

Any way I can send you a cup of joe?(or something equivalent)

1 Like

Back to back reviews are available under the Custom options:

1 Like

Thank you for the great app, I like the style!

There’s just one usability point I’m not getting: how am I supposed to say “I don’t know” when I forgot something?

Undo is clearly the wrong button in this case.

I tried inputting a random character, but it just tells me I’m wrong and keeps asking for the right answer, which I don’t know!

Here’s a recording showing the problem: Jakeipuu - I don't know!? - YouTube

I’m using version 1.3.1 on Android.

Pull up from the bottom in the middle.

So I’m supposed to just study the card again and input the right answer.

Edit: NO see below


How do lessons work? I can’t find an obvious way to go to the next item.


Just swipe at the top where the vocab word is, like you’re turning a page. I think you should also be able to select one of the tiny gray circles at the bottom, but unfortunately I’m going off of memory at the moment – currently have no lessons to double check this.

I see the issue I was having here. I was scrolling inside the submenu here, which on the last page has no action.

I think there’s totally an UX improvement to be made here so its more obvious.

There’s an article on The Verge about this, published in October.

Today, Apple confirmed to us once again that the rule is more lenient than it sounds: “free apps acting as a stand-alone companion to a paid web based tool” don’t need to use IAP as long as the apps themselves don’t offer purchases, and as long as the apps themselves don’t ask users to make purchases outside the app. Developers can advertise different pricing on the web, TV, billboards, or anywhere else outside the App Store, the company tells The Verge .

If this remains correct, WaniKani companion apps should be fine to get published in the App Store without needing to offer in app payments.

(I also professionally develop mobile apps, using the same technology as Jakeipuu, so I’m following closely how this goes)


I love the beautifully clean interface! I am actually tending to use this app instead of the web nowadays :open_mouth:

My favourite thing is the batch size quick selector, and being able to select only ‘Current Level’ items - very useful, thank you, great work @Pakkapao !

It’s great to see Thai user on WK ! :smiley:

Jakeipuu is great. Thanks a bunch for your hard work.

On Android, the audio clips usually cut off just before the end of the word. Has anyone else run into this and fixed it?

This is great app, I was using Tsurukame, but now I am using Jakeipuu.

There is some strange behaviour (iOS) though for some words - I have seen it on noon-moon and the below wide-> wife, when my input was ‘wide’, it has been marked as correct but was changed into ‘wife’. Not sure if this is how it works on vanilla WK also.

I hope app will keep on living - it is very nice!
Thank you.