Installing Wanikani Open Framework

I followed everything on the guide and downloaded the script “double-check” and open framework but it doesn’t seem to be working. The option button does not appear when I doing my reviews. I am using other extensions on Chrome but I am sure that they do not interfere with tampermonkey. Here are some pictures of my screen:




In the Javascript window, try clicking on the bottom-most error… the one with “review:1” on the far-right… and post a screenshot of any additional info that comes up.

None of the other errors seem to be related, and I don’t see any indicators of the usual problems.

… But now that I think about it for a moment, you may need to go to the “API Tokens” section of the WaniKani menu and make sure there’s at least one API Token generated. If not, try generating one (just accept the default settings, and you can name it whatever you want), and then try your Reviews again. If you end up having to generate a token, but it still doesn’t work, let me know.

Here is a screenshot of the error⬇️ I generated a token few months ago and it says that the token is still active.

Seems like maybe it is failing to load something. Let’s try clearing Open Framework’s cache. In the Javascript console, enter this command:

wkof.file_cache.clear()

Then try reloading the Review page.

Doesn’t seem to be working, is it because I can’t access google extension store and other google services and downloaded tampermonkey using a crx file instead?

I downloaded other scripts and they are working fine :thinking:

I took a deeper look at the call-stack on the ‘reviews:1’ error, and I think it might be failing to load either the Menu or Settings module of Open Framework. Could you look check the Network tab (in the Developer Tools), type “Open Framework” into the filter box (far left side), and look at the Status column for any errors?

These are the only two errors I found, I couldn’t find anything when I typed in Open Framework. Does the double-check and open framework happen to use any resource from google or other websites? Because I’m worried that they are inaccessible in my area.


Yep, everything solved after I came to the US. :upside_down_face:

Google services :clown_face: