Installed scripts on Safari 13.1, nothing working

Hi everybody!

As I had a laptop breakdown some time ago, I just reinstalled Tampermonkey and quite a lot of scripts, but nothing seems to work.
I did it exactly the same as back then, but this time nothing happens…

  • Tampermonkey is activated
  • The scripts are activated in Tampermonkey
    -WK Open Framework is active and as #1 on top of the scripts list
    -On WK homepage, Tampermonkey shows me 7 active scripts (heatmap, level duration, etc.), but nothing gets displayed on the page
    -No script showed up when I did my lessons (I can’t check for reviews right now, I have none ^^)
    -I’ve tried relaunching Safari and logging out and in again in WK

I guess I might have to enter my API key into some of the scripts, but not into all of them, right? So this shouldn’t be the main problem. And I hadn’t done that at all last time…

I hope this question has not already been answered somewhere else, I had a look but didn’t find anything. If it’s the case, please let me know!

Cheers and may the Crabinator be with you,


I am not a mac user so I may be out of my league. But I will do my best.

API keys should not be an issue, at least not with the scripts you named. WK open Framework takes care of the API key behind the scenes and most scripts use WK Open Framework. Unless you have one of the rare scripts that doesn’t use WK Open Framework you won’t need an API key.

Let’s do a sanity check first. If you click on the Tampermonkey icon something like this should show up.


You should see the enabled checkmark on the top line. If you don’t this is your problem. Click on it to make sure it is enabled.

Then all your scripts sliders on the left hand side should be on the green position. If they are greyed this is your problem. Click on them to make sure they are green.

If this doesn’t help then open your console to see if there are error messages. You use Option + ⌘ + C… Something like this should open.

Make sure to select the console tab as indicated in the arrow. Then post a screenshot of what you find there. This may tell us if there is a problem with the scripts.


Another recommendation I would say is to remove ALL scripts except for the WK Open Framework. Install one script at a time to verify each one works before installing the next. It is possible that one of the scripts is breaking everything else.


Yes this. This is a good procedure. No need to uninstall and reinstall. Just disabling the script in Tampermonkey will do.


Just disabling the script in Tampermonkey will do.

Ah, right! Makes it a little simpler. Forgot about that option :smiley:

I had similar issues with the MS Chromium Edge Canary build a few weeks ago. Turns out there was something done from one day to the next that broke Tampermonkey. 3-4 days later, after using the regular Chromium Edge I came back to Canary and they all worked again.

And the only other recommendation I have for @Woki is, try another browser. Install Chrome or Edge (Chromium works on Mac) or Firefox or Opera and install TamperMonkey and each script and try again.


Hey @prouleau, @slerched, thank you very much for your quick answers and help!
:bowing_man: :pray:

Short version: it works again! Apart from a few scripts, but I’ll look in the corresponding threads.

Oddly enough, as I turned on my laptop today and went on WK, it seemed to work… I can’t explain this to myself, since I had tried to relaunch everything yesterday. Doesn’t make sense to me that restarting the laptop could solve anything…

Anyway, I’ve done the sanity check, Tampermonkey was enabled and the scripts were all on green positions. Here is a screenshot of the console. There seems to be two errors

Then I’ve tried your advice on disabling all scripts and then enabling them one by one.
None seems to cause a global bug but some do not work properly or seem to want an API token but don’t tell me where to insert it. Example Sentences asked me for it when I started a lesson but I could sort that out.

Capture d’écran 2020-10-21 à 12.12.05

The script code on Tampermonkey also shows some error, e.g. at this point:

But that’s an issue I’ll try to sort out by looking in the corresponding thread :slight_smile:
Niai Similar Kanji and Unobstrusive Stroke Order don’t seem to work either, so I’ll also have a look at the threads. Stroke Order asks me to download and install the front, which I’ve done, but still doesn’t work. Same for that, also.

PS: I guess I’ll try another browser if I still have problems or can’t run some scripts at all… but I quite like my good ol’ Safari :grin:

1 Like

Edit: I’ve just started to do a lesson and when pressing ENTER after typing my first answer in the quiz, everything disappeared, the loading WK came up, and I was thrown back to the beginning of another lesson with different or some of the same items…
I’m confused… I guess I’ll check again every script to find the culprit…

You seem pretty good at navigating this technical stuff. :+1:

The first error on the console refers to a server error. There is a link in this message. Maybe the server is down and you need to wait for it to come back on-line, Maybe the link is dead. You may test the url in your browser to see what happens. If you can’t get it to respond after waiting for a while there is a strong possibility that it is down permanently.

The second error refers to a security policy in your browser that blocks a script. There is a strange number on the same line on the right-hand side. If you mouse over you may be able to get a clue as to which script this is. The console is not good at identifying Tampermonkey script so there is a possibility that you will be out of luck. In any event you may want to check your security policies to make sure your scripts are not blocked. I don’t know about Safari security policies so I can’t guide you in this process.

For the Tampermonkey error you may mouse over the yellow triangle to get additional information and post a screenshot of what you see. Yellow triangles are not errors, they are just warning about something. They are usually not worrisome but let’s check it out to make sure.

There has been a change in the Wanikani API effective at the beginning of September. Scripts using the old API have stopped working and will never work again unless someone upgrades them to the new API. You may have some scripts in this situation.

When that happens again go immediately to the console and take a screenshot. Error messages relevant to that event might have shown up.

1 Like