Google IME has GONE INSANE [Suddenly hirigana Dvorak?!] [Solved.]


#1

I don’t know what happened, I haven’t changed any settings to Google IME… but when I swapped from the J [A] (romaji) to hirigana, it does the following:

The Y now becomes the ん hirigana right away, A on my keyboard becomes ち… I don’t know how the keymappings got switched. It reminds me of typing in DVORAK on this keyboard.

(On Windows XP, I have Microsoft IME, and also downloaded DVORAK IME, German, and French, so I have a lot of languages to cycle through. On this drive, Windows 7, I only have Google IME… Always thought it was weird that the “default” since installing it is “Japanese”… only with romaji, rather than ENGLISH… and that when I swap to Japanese, it’s romaji instead of automatic hirigana… I had previously done things with my settings - that worked when I made those changes!!! But I’ve only just booted up my system for today… and suddenly I’ve got this… I’ll type the QWERTY line as an example…)

たていすかん

That was QWERTY.

A) why are single keys hirigana now?
B) why did it change?
C) How can I change it back? (WTF weird setting, when my keyboard is ENGLISH!!!)

Has this happened to anyone else?


#2

Hiya! I just tested it out on my own laptop and figured out what’s up.

  1. On the language toolbar and language set as Japanese, look for the button “Tools”
  2. Select “Properties”
  3. Under “General” tab, look for “Input Method”.
  4. Change the value from “Kana Input” to “Romaji Input”
  5. Click Apply, OK, etc.etc.
  6. Now go back and test it again :slight_smile:

#3

There is also a ‘restore default’ settings button on the same page that should put everything back to how it was when you first installed it.


#4

Oh… Maybe. I did switch to “kana input” at one point… so that it would stop being auto-romaji when I alt-shift over. I want to type in Japanese with my IME, not English… Hrm… I will try that.

@namste - I clicked “restore default” about 5 minutes before making this thread. Oddly, it did not work.


#5

んらなちりのまちりのまち

@zheinpathos - It’s currently on Romaji input mode from the previous “default settings” click already… NO LUCK. (See above.)

T_T


#6

For another terrible example, below is konnnichiha (as typed).

のらみみみにそくにくち

(Edit: this was after clicking DEFAULT settings AGAIN.)


#7

This


#8

YES! YES!

That totally happened! How do I undo it? My computer’s language is set to English, so WTF did I do?! XD


#9

I don’t know, but you could use the image as reference if you can’t get it fixed.
Probably makes typing faster, or are there other disadvantages?

It never happened to me.


#10

Is your keymap style set to MS-IME?


#11

Well, considering I have a normal, NA QWERTY keyboard with none of the hiragana on my keys, it’s not going to make typing any faster. Especially if it swaps back just as randomly. (I’ve been touch typing for 20 years, my WPM is fast, and still can’t keep up with my brain, usually today, totally can… I’m feeling really sleepy… Maybe I need coffee… oh… I sooo need coffee… I think this extra little aside have just given me today’s life mission…)

I wonder if a restart will fix it. Worst case, uninstall and reinstall, I suppose… but I’d really like to know for sure how I messed it up so I don’t do so again.

I currently want to do none of those things… It’s a good thing WK has it’s own IME built-in, otherwise I would’ve royally screwed up my reviews just now.


#12

Yes, it was… I saw that.

Is that the problem?

EDIT: I just opened up the “customize” next to that, and notice a lot of keys I don’t have… “Eisu”… “Hankaten/something”, etc. In addition to ENTER still being “commit”… and all kinds of (go back go forward) commands I didn’t know were things.


#13

That’s what I use.

Somehow you’ve set your keyboard to the Japanese standard layout (JIS), that explains why the keys don’t match the QWERTY layout. Not exactly sure how you’ve managed that though, perhaps some key combination does it, or you’ve changed some localization settings on your Windows. Check what is your default input language of your Windows, maybe that somehow got changed into Japanese.


#14

I’m positive I didn’t touch that, but I guess I’ll have a look…

It must’ve been from the “kana input” that zheinpathos mentioned… but maybe that switch didn’t take effect until a reboot…?


#15

Ah yes, that’s correct it’s from the Kana input thing. You need to restart the application before it takes effect, it even says that after you change it.


#16

@namste - Well, it did have Japanese as my primary input method, and I had noticed a JP up in the upper left corner whenever booting and shutting Windows 7 down since installing the IME, although other than having the computer auto start up as J [A] by default, it didn’t seem to do anything else. I’ve been using the Google IME for at least a week… But I switched English back to my default/main language for applications.

Still, weird though…


#17

This reminds me of when I accidentally changed my skype interface to arabic. Twice.


#18

Does it!? It totally didn’t!

… >.> …

Although, I half remember some dialog box popping up asking me if I wanted something to be permanent and just being like “yes, stop telling me things” I clicked OKAY… so … maybe that was it and the wording was weird and I didn’t understand. I honestly have no recollection of it mentioning a reboot.

Well, that just means a reboot will solve this. (Hopefully!)

I’ll try that now.

Thank you, @namste!


#19

Weird thing overall, maybe Windows decided that you’re a native Japanese person now and changed everything for you.


#20

Did it fix?!