Font display changed

Hey guys,
I installed Google IME on my new computer yesterday and I think that messed up with the way fonts are displayed in my browsers (Chrome and Firefox). I already tried some things I found online but nothing worked.
The way japanese characters are being displayed now is horrible. It doesn’t look like the problem is chinese font instead of japanese. Here are some random texts:

image

Can anyone help me?

1 Like

The IME installed some fonts for you. WK prioritizes one of those fonts over the one you had before. This is the way it’s supposed to look

2 Likes

Hm, I see. But it’s not just WK, everything displayed by the browser is like this.
Is there a way to prioritize another font instead of this one? I prefer the way it was before. Maybe it would work if I uninstalled this font from my computer?

I believe you can set the default font in most browsers, but that probably won’t change anything on WK. Uninstalling the font would be fool proof I guess

1 Like

I just tried uninstalling it and turns out it’s impossible because it’s a “system protected font” :sweat_smile:
I guess I’ll just have to live with it

1 Like

If you go to “advanced” under font preferences you can choose your own font and if you uncheck “let web pages choose their own fonts” I believe you can force yours to display on most sites. (Not sure if it’ll work on WK or not though.) I think chrome has something similar.

Edit: oh and make sure you select “Japanese” on the “Fonts for” dropdown.

5 Likes

Thank you very much. It worked for WK too on Firefox. :grin:
I just couldn’t find how to do this in Chrome

I was able to set it on chrome using a combination of these two extentions Stylebot and Advanced Font Settings. Now I have a nice serif style for japanese fonts for any website :slight_smile:

With some minor issues like this :sweat_smile:

image

Thanks for the help.

No problem! Not sure why chrome doesn’t have this kind of feature, seems like an important accessibility option. Glad you got it working with plugins. :slight_smile:

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.