The fonts became too bold and illegible


#1

Hi,
I’m not sure if it’s something with my setup but the fonts on my desktop (Firefox 65.0b8 on Windows 10) became barely legible tonight.

Now the font seems to be Meiryo, as in the screenshot below:
Meiryo

I’m pretty sure it used to be a differnt one, maybe Yu Gothic, as in the picture:
Yu%20Gothic

The only thing that might’ve made a difference on my side is that I installed Japanese language and IME on Windows 10 the other day but I haven’t notice a difference until now.

Have there been an update to WK’s CSS?

Is there a way to change the default font on my end?


#2

The boldness and illegibility of the font is turning me on


#3

The Japanese pack probably installed some fonts that have higher precedence in WK.
You could set the default font for all pages in the browser, or use a user style with a browser extension (like tampermonkey, but for CSS). That should be a one-liner.

Also this:


#4

Maybe it’s just me but those two screenshots look really similar…? Font in the top one is a smidge shorter and bolder but it it seems pretty subtle.


#5

Yeah, if one of those is supposed to be illegible, I’m not seeing it.


#6

Yeah, of course it was an exaggeration but the screenshot didn’t represent the worst case example. The new font has very thick strokes and little gaps between them making it more difficult to read (and it’s just plain ugly :wink:).


#7

Of course therw is value in learning to read the less readable font, as you’ll come across a range of fonts at different levels of legibility in the wild


#8

Installing the Japanese Language Pack for Win10 is what did this to you. Your assessment is correct, it was Yu Gothic before and changed to Meiryo. To fix this in Firefox click the three bars in the top right corner of your browser window and go to ‘Options’. There, under ‘General’ you will find ‘Language and Appearance’. Click the ‘Advanced…’ Button. Select Japanese and choose your font. Then uncheck ‘Allow pages to choose their own fonts, instead of your selections above’. Done.

This won’t just affect WaniKani though (so put the check mark back after you’re done with WaniKani for the foreseeable future), but it is the only way I know of to change back to Yu Gothic, since Windows won’t let you uninstall Meiryo.

Also consider searching for the Jitai Font Randomizer here on the forum to, as the name suggests, randomize fonts (during reviews only), so you can get used to the same kanji in different fonts. Imagine only being able to read English in Arial or Times New Roman. But not in Vivaldi, Mistral, Bradley Hand ITC, or friggin Jokerman, or Curlz MT.


#9

You know there have been studies that suggest that having tests printed in harder to read fonts force the conscious problem solving part of our brain to engage, so this might actually be a good thing.

It’s mentioned in this incredibly interesting video: https://youtu.be/UBVV8pch1dM

Edit: though, like others, I don’t really see it as much harder to read tbh; they both look like different, perfectly legible fonts…


#10

Agree! Maybe you could provide a better example? more strokes or something? @d-hermit


#11

Sure, here’s a better comparison:

You can see that font on the left is a bit smaller (the size in pt is the same) and has lower contrast (strokes are fatter and closer together).

So of course, it it’s not illegible but I find it more difficult to read. And I also find it more ugly and since studying kanji is a hobby I’d prefer to do so in a more pleasant font :slight_smile:

I see that using a custom script should probably be the best option as I don’t wont to override the fonts on all websites.

There’s quite a bit more responses to a topic about fonts than I’d expect, thanks everyone!


#12

I ended up deleting the font altogether. It was a “protected system font” but it’s possible to delete it by taking ownership of the font file, giving the admin user full permissions and then removing it.

I’m pretty sure it wasn’t there before I installed the IME, so I hope nothing breaks :smiley:


#13

If you do decide to use Jitai, make sure you download additional fonts (or else it’ll only randomize a few fonts). I personally like these:

  • “EPSON 行書体M”
  • “EPSON 正楷書体M”
  • “EPSON 教科書体M”
  • “nagayama_kai”

You also have to edit the Jitai script to add the ones you want to use.


#14

where is the option to do this? I installed the IME keyboard too, and i hate the new font, it’s way too thick and bold


#15

Open the Fonts folder, right click on the font you want to delete, got to Properties, in Security tab (if I’m not mistaken) got to Advanced settings, then find Owner -> change, then you’ll need to type the name of the group you want to change the ownership to. Type “Administrators” and click a button to the right of the text field to find the exact group name. Accept chanes, close the dialogue and go to the font properties, Permissions, now grant All Rights to the Administrator group. Save and closs the dialogue.

Now you can delete the file. Of course it assumes that you’re using a user account with Administrator rights.

You will need to delete two font files: regular and italic.