{"error":"Unprocessable entity","code":422}

When trying to start new lessons session, I am greeted by the response in the title. Is this a common issue, or specific to me right now?

3 Likes

I so far hadn’t encountered it, but I’ve seen post about the same issue:

3 Likes

Might be something going on right now. I will check later.

I also did not seem to be able to logout either.

3 Likes

Again, the same problem @kloxy さん has:

3 Likes

Seems like somebody updated their form validation code and didn’t update the actual form itself

Shame! Ignominy!

4 Likes

I know some of those words

5 Likes

oh i’m glad i’m not the only one – it works if i log in on firefox btw and also on a chrome incognito tab – but i also tried clearing cache and cookies and restarting my laptop (good ol’ power cycle) but still seeing this on a non-incog chrome window

1 Like

Happening to me too (using Kiwi Browser). Seems there’s no such issue whenever I disable Tampermonkey. So, my workaround is to disable Tampermonkey first when seeing that problem, open WaniKani via a new tab, then enable again afterwards.

1 Like

ooh okay that worked…

it’s probably a script that updated recently?

Possible. I’m not sure which one though, and it will take time to check one by one :sweat_smile:

if you go onto your tampermonkey dashboard, you can sort by last updated,

there were 2 userscripts that updated within the last 2 days for me:

  1. Advanced Context Sentence 2
  2. Rendaku Information

I’m going to disable these and logout and login see if it works

EDIT: okay even with these disabled, I’m unable to logout :laughing:

For me, these are the 2 scripts updated within last 28h:

  1. WaniKani Pitch Info
  2. Advanced Context Sentence 2

If not the scripts, maybe something’s wrong with the Tampermonkey itself? :flushed:

1 Like

maybe :weary: i might uninstall and reinstall? idk cos its effort to go back and install all the scripts again haha

2 Likes

I’m not experiencing this error and I never have, but for the past few weeks now I’ve had problems with WK not loading scripts properly in reviews. Sometimes they show up the first time, sometimes it takes 3 refreshes, sometimes it takes more. They do eventually show up, though. It doesn’t annoy me enough to make me want to investigate it but I figure that might help you in figuring out what’s going on, even if it isn’t the same error.

2 Likes

I’ve been having the same problem of scripts taking multiple refreshes to load. I remember @seanblue mentioned it’s likely due to a bug in Tampermonkey.

The problem of
{“error”:”Unprocessable entity”,”code”:422} is quite new though (only happened in the past 2 days, I think). Not sure if it’s related with the other problem.

2 Likes

I had that one too, the only thing that helped me was reinstalling Tampermonkey.

1 Like

I’ve been avoiding this method because it takes effort to reinstall each script again :weary: but if it works, maybe it’s worth a try.

1 Like

You can export and import your script collection from the Tampermonkey utils

3 Likes

Hey Everyone! I’ve been keeping an eye on this issue and I see that more than a few people are experiencing similar problems. It looks like it may be related to a Chrome update or Tampermonkey, or both. If you’re experiencing this issue feel free to reach out to hello@wanikani.com and let us know:

  1. The description of the error.

  2. What browser and OS you’re using (and version).

  3. If you turned off user scripts and still got the error, or if you solved it yourself! We would love to know! :sunglasses:

EDIT: I received a response from a user who first experienced this issue before the forum posts were made and they did some troubleshooting and found that uninstalling and re-installing the Chrome browser did the trick. They did make sure to export their user scripts before they did the uninstall though, so if you use them, you might want to do that before you try this.

As always, if the issue persists for you, please feel free to reach out to us!

-Nick at WK

8 Likes

Unprocessable entity? You’re too powerful! :open_mouth:

2 Likes