Beginning of audio playback cut out

Hello,

I’ve noticed that on my new laptop the first half-second (or less) of audio doesn’t play when an audio file plays automatically during review. I can go in and click the speaker icon and it will play both the audio files (male and female) with no issue, but when it plays the file after I enter the reading of a vocabulary word, it’s typically cut off.

I’m not using any additional scripts. The laptop is new, and was a fairly top-of-the-line gaming model at the end of 2021. I have a decent wifi signal (~50Mbps) but even when I was using gigabit service (in a different country) and getting >250Mbps, this was happening.

This issue seems to be the same as on this post: Sound truncated

That one didn’t seem to get resolved.

I’ve tested through the 3.5mm headphone jack, the laptop speakers, and monitor speakers via HDMI.

I’m not sure what to make of it, but it’s frustrating that my new laptop does this, while my junkie old work computer, and older laptop don’t have this issue.

Any ideas to try tweaking would be appreciated.

Do you get the issue if you have background sounds on like music?

2 Likes

I have the same thing, but I think it as to do with the device playing audio. There is some audio cut when I use my Sony bluetooth headset, but not when I use my wired 3.5mm headphone nor when I use my stereo speakers.

Using Windows 11 with the latest Firefox on both systems.

1 Like

So I just tried a few minutes of review with music streaming in the background and did not experience this issue. All the audio files that automatically played when I got a vocabulary reading correct were the full sounds with no leading truncation.

I’m not sure what to make of that.

I’m using Chrome, on Windows 10 Home. I saw something about this being an issue with Bluetooth audio devices, but I’m not using Bluetooth.

Might be some weird power saving standard enforced by EU. I have the same problem with my speakers but not with headphones.

1 Like

Interesting. I’ll see if I can find anything out from the manufacturer (Razer).

I have this issue with BT headphones thanks to power saving.

My solution was to play music at zero volume at the same time as doing reviews.

I wonder actually if WK could be modified via a user script to play a bit of silence just before the speech to work around this…

3 Likes

I just tried playing through my laptop’s built-in speakers again, because I realized I may actually have never used the speakers for WaniKani before (having relied heavily on headphones). So far it’s playing the full audio file, although I haven’t tested it enough to be conclusive.

(Now the issue is that I’m getting this weird “spatial echo” even though I have that feature turned off).

I’m going to try again tomorrow, as it’s bedtime, and see if it actually is an issue with using non-built-in devices (which would suck).

In my experience, the full audio is played the first time you play it, but the beginning is clipped if you play it again without refreshing/changing the page. I think the first time the audio file has to be downloaded from the server, and after that it’s cached (until the page is refreshed/changed). I always wondered if it had something to do with a bad browser optimization, but I really have no idea. I use Chrome.