Answer field not taking focus when reviewing new lessons

I’ve noticed in the last day or two that after I’ve done a set of lessons and click the button to start the first lesson review the answer field is not taking focus anymore on the first one. So I start typing and nothing appears until I click in the answer box.

I’ve tried this with all userscripts disabled to rule that out. I’m using Chrome on MacOS if that helps.

Note, it isn’t doing this in normal reviews, just the review after completing lessons.

Anyone else seeing this?

9 Likes

I’ve not consciously noticed for lessons - but I only lesson with the new rollouts on Thursdays, so I probably don’t get enough chances to notice. I do notice that any shake animation (warnings kun vs on or vocab vs kanji meaning etc) take the focus off the answer field. So there have definitely been updates that affect that element.

4 Likes

I’ve not noticed that one yet but I will look out for it on my next reviews.

Yesterday and today it did that with me (using Brave on Windows, here), but it started right after my laptop updated (24 hrs or so ago) so I’d assumed it had something to do with that, but it seems that may have just been coincidence

I had the same thing with my lessons this morning. If it helps, on Windows (Microsoft Edge), pressing the return/enter key automatically brings the focus back into the answer box without having to move your hand from the keyboard to the mouse to click into the answer box. It’s a little irksome, but manageable. I imagine the same would hold true for MacOS.

3 Likes

This behavior has been noticed at least two months before, but for some it disappeared. It re-appeared for me about three weeks ago. It happens as you all describe, and it does for me in a Safari and Opera environment. @RachelG perhaps something you and the team need to look into?

5 Likes

Oh that’s annoying. It has never happened to me though.

Happened to me too probably 2 or 3 days ago and still is. And thanks for describing it I didn’t know how to say it in English.

1 Like

Last time this happened to me I just had to press Enter one time before typing my new answer.

2 Likes

Yet another Friday deployment…

3 Likes

You’re right. I just tried that and it does work on MacOS.

2 Likes

can confirm that this has been happening to me too (Firefox on MacOS), started some days ago. haven’t done any lessons yet today, but yesterday it was still doing so.