Allicrab broken on ios 11.3

Anyone else have the problem that Allicrab on ios 11.3 keeps hiding the keyboard after every answer? It is so annoying to tap into the answer field every single time now… :(((
No answer from the dev either, is Allicrab abandoned?

I have 11.3 and my keyboard is working just fine in AlliCrab during reviews :thinking:

Maybe you can try restarting the app or your device? (AKA try turning it on and off again :durtle_the_explorer:)

It is working for me too, but each time I enter the answer, the keyboard disappears. Then I have to tap into the answer field again and it reappears. Before I didn’t have to tap each time, the keyboard stayed and I could just type away…

1 Like

I had this problem in a different WK app in android, but I don’t remember how I fixed it… I think it might have depended on what keyboard I was using. Have you started using an IME recently?

I am having the same issue since updating my iOS. Having to tap in the answer field to make the keyboard return definitely slows you down.

what a shame. looks like we will have to live with it

I don’t think Allicrab is abandoned, the dev last updated the GitHub page for it in March. (Not sure why he’s been updating the GitHub page but not updating the App on the App Store, since there hasn’t been an App Store update in 8 months)

Since it’s open source, even if the dev stops working on the project, depending on the license Allicrab uses, it might be possible for somebody to fork it, fix the bug, and try to add it to the App Store, but the odds of that happening are extremely low. (The odds of someone forking it, fixing the bug and then the rest of us having to compile and install it ourselves is slightly higher, but also more difficult) Or maybe the bug will go away with the next iOS update… Who knows?

Wow, hah - thought I was going crazy with the keyboard disappearing. Is this also how it always worked on the stock WK webpage as well?

not sure. It is quite frustrating though…

I had this problem trying to use the website on my Samsung tablet with firefox; it also caused the review item area to shift up each time keyboard popped up making the top third of the character disappear. It grew old v. quickly and I decided to just stick with the pc.

I didn’t have this problem on the tablet using Chrome, but couldn’t install any userscripts on the tablet with chrome, thus the 30 min firefox experiment.

I have the same problem since updating to 11.3. Fingers crossed that the dev will see this!

This issue is fixed in the 3.0 beta version. I have been trying to avoid releasing a new version of the App Store version with fixes since this would take a fair amount of work and any spare time I do get I would prefer to pour into the new beta. The new 3.0 beta is a ground-up rewrite of the app (though it looks pretty much the same, the code is substantially different) based on the currently-unreleased WaniKani v2 API. I won’t release the new 3.0 version until this API v2 is released.


Does the new beta have support for the reorder script (please-o-please)?

1 Like